TAPIMaster® 3.2.0 Anwenderhandbuch

Inhalt

Einführung

Vorteile von CTI

Systemvoraussetzungen

Leistungsumfang

Installation

Client

CTI Switchboard

FAQ

Preise

Kontakt

Send feedback to TAPIMaster

© 2020 Tino Kasubke. Alle Rechte vorbehalten.


Einführung

In allen mittleren und größeren Firmen gibt es Telefonanlagen. Leider setzen nur die wenigsten Unternehmen diese Anlagen optimal zum Nutzen von Firma und Kunden ein. Die Mitarbeiter verbringen zu viel Zeit damit, Rufnummern von gelben Zetteln abzutippen, die Sondertasten des Telefons nicht zu verstehen und vor allem warten sie regelmäßig darauf dass sich die Kunden bei ihnen melden anstatt hier selbst die Initiative zu ergreifen und die Kontakte zu pflegen. Das ist nicht immer nur eine Frage mangelnden Elans, sondern auch fehlender Hilfsmittel für rationelles Telefonieren.

Hier setzt TAPIMaster® an indem es das Telefonieren an Computerarbeitsplätzen vereinfacht und beschleunigt. Komplizierte Tastenkombinationen am Telefon werden durch Mausklicks ersetzt. Rufnummernidentifikation, Gruppenfunktionen und Telefonbücher beschleunigen die Arbeit. Durch die Integration in bestehende Programme lassen sich Eingabemasken steuern und Kundendaten gezielt anzeigen. Der Benutzer schafft in der gleichen Zeit mehr Anrufe. Die Erreichbarkeit wird verbessert. In der eingesparten Zeit können Sie Ihrer Kundenkontakte weiter ausbauen.

Es ist nicht Hauptziel die Telefongebühren im Unternehmen zu senken. Mit Hilfe des Produktes sollen im Gegenteil die Kundenkontakte noch ausgeweitet werden. Gerade in diesen wirtschaftlich schwierigen Zeiten in es wichtig den vorhandenen Kundenstamm zu halten. Eine intensive Kontaktpflege ist eine wesentliche Bedingung hierfür.

Hier bekommen sie eine CTI Software zu einem angemessenen Preis. Sie bietet eine umfangreiche Telefonanlagenunterstützung und Integrationsfähigkeit und macht sich in kurzer Zeit bezahlt.

Sie können die Software vor dem Kauf fast uneingeschränkt testen. Da Sie TAPIMaster® bis zu 4 Clients kostenfrei nutzen können, müssen Sie in Kleinunternehmen auch bei angespannter Finanzlage nicht auf CTI verzichten.

TAPIMaster® ist eine C/S basierte Software, der CTI-Server läuft auf einem Computer welcher mit der Telefonanlage verbunden ist. Die Clientsoftware wird auf den einzelnen Computerarbeitsplätzen gestartet.

TAPIMaster® ist für folgende Zielgruppen geeignet:

·Softwarehersteller, welche ohne Aufwand ihre Software mit Telefoniefunktionen ausstatten wollen.

·Firmen, welche CTI an ihren Arbeitsplätzen einsetzen wollen.

·Hersteller von Telefonanlagen, welche die Funktionalität ihrer Anlagen erweitern wollen.

Fallbeispiele

Mittels einiger Beispiele aus der Praxis lässt sich der Einsatz von CTI Software gut nachvollziehen.

Third Party CTI

Einzelplatz mit ISDN Telefon

Multiuserbetrieb im Bürogebäude

Bank mit Filialen

AS400 in einer Spedition

ACD Light im Einsatz


Third Party CTI

Architekturansicht

TAPIMaster® ist eine Third Party CTI Lösung. Hierbei ist ein Rechner (CTI-Server) mit der Telefonanlage verbunden, meist über USB oder Ethernet. Auf dem Server ist ein so genannter TAPI-Treiber installiert. Dieser ist vergleichbar mit einem Druckertreiber, statt eines Druckers benutzt TAPIMaster® diesen Treiber zur Steuerung der Telefonanlage. Die Arbeitsplatzrechner haben eine Verbindung zum CTI-Server. Mit den TAPIMaster® Clients können die Benutzer ihr Telefon bedienen.


Einzelplatz mit ISDN Telefon

Situation

Hubert B. betreibt einen Kurierdienst und hat mehrere Fahrzeuge im Einsatz. Er beschreibt seine Probleme so:

"Die meisten Aufträge bekomme ich von Speditionen. Die rufen mich an wenn irgendwo Ware liegen geblieben ist und unbedingt zum Kunden muss. Davon allein kann ich jedoch nicht leben. Also rufe ich jeden Tag zwischen zwei- und dreihundert potentielle Kunden an und frage nach Aufträgen. Das dauert natürlich seine Zeit. Oft schnappt mir die Konkurrenz die Aufträge vor der Nase weg und die Fahrzeuge kommen leer zurück.

Ich habe zwar alle Kontakte im Outlook. Die Rufnummern tippe ich von Hand ab. Eine teure Telefonielösung kann ich mir aber nicht leisten."

Mögliche Lösung

Hubert B. braucht ein Outlook-Telefonbuch mit dem er schnell per Mausklick wählen kann. Eine Freeware-Lösung für einen Arbeitsplatz wäre ideal. Benötigt wird nur noch ein TAPI-fähiges ISDN-Telefon oder eine kleine TAPI-fähige Telefonanlage.

Als CTI-Software kann die Einzelplatzlösung von TAPIMaster® genutzt werden. Der Rechner wird mit dem ISDN-Telefon verbunden und der TAPI-Treiber installiert. Wichtig: Die Hinweise des Herstellers sollten beachtet werden. Client und Server der TAPIMaster® Software werden auf einem Rechner installiert. Der Client enthält ein Outlook-Telefonbuch, aus dem zügig große Mengen an Anrufen getätigt werden können.


Multiuserbetrieb im Bürogebäude

Situation

In einem Bürogebäude einer Versicherung arbeiten mehrere hundert Angestellte. Jeder Arbeitsplatz beinhaltet einen PC und mindestens ein Telefon. Als Betriebssystem wird Windows 7 benutzt. Die Firma verwendet Software welche eine eigene Programmierabteilung hergestellt hat. Bis zu 50 Anrufe kommen täglich pro Arbeitsplatz herein. Im Schnitt fällt täglich eine halbe Überstunde an. Die Firmenleitung lässt die Arbeitsabläufe durch externe Berater prüfen.

Lösungsansatz

Die Berater kommen zu dem Ergebnis dass pro Anruf etwa bis zu einer halben Minute eingespart werden kann. Voraussetzung: Die Software der Firma müßte die Telefonieschnittstelle unterstützen. Die Anrufer würden in der Mehrzahl identifiziert, die Kundendaten automatisch geladen und die Probleme zügiger abgearbeitet. Rufnummern müssen nicht mehr von Hand eingetippt werden. Allerdings stellt die Einarbeitung in die Telefonieschnittstelle ein gewisses Hindernis da. Es wird empfohlen eine bestehende Telefonie-Programmierschnittstelle zu verwenden. TAPIMaster® verfügt über eine solche Schnittstelle.

Umsetzung

Ein Techniker des Anlagenherstellers installiert die neueste Firmware in die Telefonanlage. Der Telefonieserver wird mit der Anlage über ein Netzwerkkabel verbunden. Der Techniker lädt den aktuellen TAPI-Treiber der Anlage auf einen ab jetzt Telefonieserver genannten Rechner. Mit dem TAPIMaster® Leitungsbeobachter überzeugt er sich von der Funktion des Treibers.

Jetzt installieren die Programmierer den TAPIMaster® Server.Sie machen sich mit dem SDK vertraut. Die Wahl aus den Kundenlisten ist in kürzester Zeit eingebaut. Bei herein kommenden Anrufen wird jetzt automatisch der Ordner mit den Daten des Kunden geöffnet. Der Sachbearbeiter sieht sofort mit wem er es zu tun hat bevor der Kunde sich meldet, das Buchstabieren komplizierter Namen entfällt.

Für die Mitarbeiter bedeutet das einen Zeitgewinn, die Arbeit wird streßfreier. Sie können sich auf das Wesentliche konzentrieren.


Bank mit Filialen

Situation

Eine Bank hat ihre Hauptniederlassung im Zentrum von Berlin. Es gibt noch einige andere Filialen in anderen Stadtteilen. Die Hauptniederlassung ist tagsüber ununterbrochen geöffnet, die Zweigstellen sind mittags geschlossen. Die Zweigstellen sind also teilweise nicht telefonisch erreichbar. Sind Mitarbeiter durch Beratungsgespräche gebunden dann können sie keine Anrufe mehr annehmen. Es besteht eine IP-Verbindung von den Zweigstellen zur Zentrale.

Mögliche Lösung

Prinzipiell könnte man Rufumleitungen zur Hauptniederlassung schalten, das dürfte auch die gängige Praxis sein. Das ist jedoch nicht flexibel genug wenn Mitarbeiter temporär nicht verfügbar sind. Mit TAPIMaster® können die Anrufe besser gehandhabt werden. Hierfür sind allerdings Fachkenntnisse erforderlich.

Jetzt werden die Telefonanlagen zentral gesteuert. Die TAPI-Treiber der (netzwerkfähigen) Telefonanlagen werden auf einem Rechner zusammengefaßt. Die Mitarbeiter werden nicht mehr nach Zweigstellen gruppiert.Jetzt gibt es eine Gruppe Anlageberater, eine Gruppe Kreditbearbeiter und andere Gruppen. Mit Hilfe der CTI-Software kann ein Anlageberater sehen wer seiner Kollegen gerade spricht. Ruft ein Kunde in einer Zweigstelle erfolglos an so sieht es der Mitarbeiter in der Hauptniederlassung. Er kann den Anruf zu sich holen. Kann er nicht weiterhelfen so lässt er dem Kollegen in der Zweigstelle eine Info zukommen. Ein Mitarbeiter in der Zweigstelle kann einen Anruf an freie Kollegen abgeben. Die Angestellten arbeiten ortsübergreifend stärker im Team. Eine genaue Beschreibung können Sie im Kapitel Besonderheiten beim Mehranlagenbetrieb nachlesen.


AS400 in einer Spedition

Situation

Eine Spedition hat ihre Filialen mit AS400 ausgestattet. Die Software schreibt das Unternehmen in einer eigenen Softwareabteilung. Um die Angestellten zu entlasten soll eine automatische Anwahl aus den Bildschirmmasken heraus möglich werden. Für die benutzten Telefonanlagen gibt es jedoch keine Anbindung an die AS400. Auch hat fast jede Niederlassung eine andere Telefonanlage. Für eine CTI-Entwicklung durch einen Fremdhersteller stehen keine Mittel zur Verfügung.

Mögliche Lösung

In jeder Niederlassung gibt es noch alte Windows-PCs. Diese werden mit der Telefonanlage verbunden. Die passende TAPI-Treiber der jeweiligen Anlage werden installiert und die Anlagen mit der neuesten Firmware versehen. Jetzt kommt TAPIMaster® zum Einsatz. Es wird nur der Server aufgespielt. Der Server hat eine IP-Schnittstelle welche von der AS400 aus angesprochen werden kann. Die firmeneigene Software kann über diese Schnittstelle die Telefonwahl einleiten. Pro Niederlassung ist nur eine Minimallizenz erforderlich, da die TAPI-Leitungen nur für die Anwahl geöffnet werden müssen und somit nur wenige Leitungen gleichzeitig offen sind.


ACD Light im Einsatz

Situation

Ein Händler für Baumaschinen hat seinen Sitz in Bayern. Die Hälfte seines Umsatzes erwirtschaftet er im deutschsprachigen Raum, die andere Hälfte verteilt sich etwa gleichmäßig auf Italien, Frankreich und Osteuropa. Etwa 20 Prozent des Gesamtumsatzes entfallen auf die Firma Bau-Michel in München, ein Kunde der schon mehrfach mit Weggang gedroht hat falls sich die Auftragsabwicklung nicht verbessert. Die Kunden bestellen per Telefon. Meistens werden Ersatzteile geordert. Täglich gehen mehrere Hundert Anrufe ein, Bestellungen und Reklamationen. Diese werden in der Serviceabteilung bearbeitet. Die Anrufe laufen bei der Sekretärin auf welche sie dann an die Mitarbeiter mit den passenden Sprachkenntnissen weiterleitet. Insgesamt läuft es im Unternehmen nicht gut. In Deutschland ist man von einem Großkunden abhängig, und das Geschäft mit Osteuropa ist nach einigen Anfangserfolgen wieder rückläufig. In einer Mitarbeiterversammlung kommen die Probleme zur Sprache.

Mitarbeiterversammlung der Serviceabteilung

Hier einige Meinungen:

Walter, Abteilungsleiter:

"Wir haben in den letzten zwei Jahren immer mehr Reklamationen. Die Kunden bemängeln unseren Service. Der Bau-Michel wird bald weg sein wenn das sich nicht ändert. Welche Probleme die unsere Abteilung betreffen seht ihr?"

Claudia, Vermittlungsplatz:

"Ich nehme jeden Tag ein paar Hundert Anrufe entgegen und leite sie an euch weiter. Ich muss dann sehen wer gerade von euch da ist und verbinde dann weiter. Mit meiner restlichen Arbeit komme ich nicht voran, und irgendwie ist das ziemlich stressig, weil alle Leute erst einmal bei mir ausheulen."

Sepp, Service Deutschland:

"Viele Leute rufen mehrfach am Tag an. Jedes mal haben sie einen anderen Mitarbeiter am Telefon und erzählen ihm ihr Problem neu. Das nervt die Leute. Der Michel will ohnehin nur noch mit Walter sprechen. Claudia kann sich aber auch nicht merken wer mit wem zuletzt telefoniert hat."

Norbert, Service Deutschland:

"Ich fühle mich in letzter Zeit einfach überfordert. Ich bearbeite am Tag meist 80-100 Anrufe, andere haben nur 20. Ich habe kaum Zeit für eine Pause. Kaum dass ich aufgelegt habe kommt schon der nächste. Die Arbeit muss einfach besser verteilt werden."

Guiseppe, Service Italien:

"Kunden aus der italienischsprachigen Schweiz landen oft nicht bei mir. Dafür habe ich oft Kunden aus Südtirol. Manchmal habe ich auch Kunden aus Polen am Telefon obwohl Thomas die bearbeitet."

Claudia:

"Ich kann nicht jeden Anruf entgegennehmen bevor ich es weiterleite weil ich oft gerade noch einen anderen Kunden dran habe. In der Hektik passieren leider ab und zu mal Fehler."

Beatrice, Service Frankreich

"Ich komme einfach nicht dazu mal Mittagspause zu machen. Mit dem Rollstuhl kann ich nicht eben mal schnell in ein Restaurant fahren und lasse mir deshalb mein Essen bringen. Bei mir klingelt aber um die Mittagszeit ständig das Telefon. Ich will mich irgendwie auch mal ausklinken können."

Fazit

·Viele Anrufer werden nicht mit dem zuständigen Servicemitarbeiter verbunden.

·Alle Anrufe gehen durch ein Nadelöhr, dem Vermittlungsplatz. Dort kommt es durch die Überlastung der Mitarbeiterin zwangsläufig zu Fehlern.

·Die Arbeit ist ungerecht verteilt, die Masse der Arbeit bleibt bei einem Mitarbeiter hängen.

·Die Pausen zwischen den Anrufen sind zu Kurz. Die Mitarbeiter bekommen schon einen neuen Anruf während sie noch den vorhergehenden Auftrag am PC bearbeiten. Hierdurch kommt es zu weiteren Fehlern.

·Die Kunden selbst haben ständig andere Leute am Telefon und werden bei mehrfachen Anrufen tagsüber nicht kontinuierlich mit dem gleichen Mitarbeiter verbunden. Wichtige Kunden wie Bau-Michel reden nur noch mit dem Abteilungsleiter.

·Die Mitarbeiter können sich nicht einfach ausklinken, wenn sie eine Pause einlegen wollen oder an einer anderen wichtigen Sache arbeiten.

Problemlösung im konkreten Fall

Die Mittagspausen sollten zeitversetzt sein. Alle anderen Probleme lassen sich mit dem ACD Light von TAPIMaster® lösen. So arbeitet das Programm:

·Alle Anrufe laufen nach wie vor auf einem Vermittlungstelefon auf. Allerdings werden die Anrufe nicht von einer Sachbearbeiterin, sondern per Computer an die Mitarbeiter verteilt. Es landen nur noch die Anrufe bei Claudia die das System nicht vermitteln konnte.

·Jeder Servicemitarbeiter bekommt automatisch eine Pausenzeit eingeräumt. So kann er die Aufträge ordentlich abschließen.

·In einer Datenbank werden Routingregeln hinterlegt: Wenn eine Rufnummer mit +48 beginnt dann versucht das Programm den Anruf zuerst an Thomas durchzustellen weil er Polnisch kann. Ebenso wird mit den anderen Ländern verfahren, so lassen sich auch Vorwahlgebiete in der Schweiz besser verteilen. Großkunden wie Bau-Michel bekommen einen bevorzugten Gesprächspartner zugewiesen. Anrufer ohne Rufnummernübertragung werden zweckmäßigerweise mit Claudia verbunden.

·Die Mitarbeiter können sich vom System abmelden. Während der Mittagspause werden sie nicht mehr gestört.

·Das System berücksichtigt das Arbeitspensum der einzelnen Mitarbeiter. Sind genug Leute frei dann werden die Anrufe denen zugestellt die bisher die wenigsten Anrufe oder Gesprächszeit hatten.

·Sofern möglich werden Kunden immer mit dem letzten Gesprächspartner am jeweiligen Tag verbunden.


Vorteile von CTI

TAPIMaster® bietet Ihnen alles was Sie zum rationellen Telefonieren brauchen. Ob Sie nun Endanwender sind oder als Softwarehersteller Ihre Programme um Telefoniefunktionen erweitern wollen.

Integration

Kosteneinsparung

Mehr Bedienkomfort

Mehr Kommunikation

Preisvorteil


Integration

Den größten Nutzen bringt CTI erst wenn sie in bestehende Programme wie z. B. Warenwirtschaftssysteme integriert ist. Hier können die Benutzer unterstützt werden indem zum Anruf die passenden Kundendaten auf dem Bildschirm angezeigt werden. Aus Kundenlisten könnte man schnell und unkompliziert den Kunden anrufen.

TAPIMaster® bietet die erforderlichen Schnittstellen für eine einfache Integration in andere Anwendungen. Im TAPIMaster® SDK finden Sie alles was Sie hierfür brauchen.


Kosteneinsparung

Mit CTI-Software können Sie beim Einkauf von Telefonen auf preiswerte Analoggeräte zurückgreifen, die Kostenersparnis pro Arbeitsplatz liegt dann oft über 100€. TAPIMaster® ist eine Anwendung welche die Ressourcen wie Arbeitsspeicher, Plattenplatz und Rechenkapazität schont.

Noch ein Wort zu den Telefonkosten. Die Telefonkosten in Firmen werden häufig mit den Telefonrechnungen gleichgesetzt. In der Praxis gestalten sich die Kosten für das Telefonieren jedoch ganz anders. Eine Anrufminute kostet z. B. 3 Cent. Die Personalkosten für den gleichen Zeitraum betragen 50 Cent (bei Gesamtkosten von 30€ pro Stunde) oder mehr. Beim Telefonieren Geld zu sparen heißt schneller zu telefonieren. 10% weniger Zeit pro Anruf spart ebenso viel Geld ein wie der Anruf kostet. Ein Wechsel der Telefongesellschaft bringt nicht diese Einsparung.

Ein Trugschluss ist es auch zu glauben, dass ausgehende Anrufe teuerer seinen als eingehende, nur weil dadurch Telefongebühren entstehen. Bei eingehenden Anrufen wird der Mitarbeiter bei seiner Arbeit unterbrochen. Er braucht Zeit, um sich auf den Anruf zu konzentrieren, Unterlagen herbei zu holen, Rückfragen zu tätigen. Nach dem Anruf braucht er Zeit um sich wieder auf seine Arbeit zu konzentrieren – so verstreichen schnell ungenutzte Minuten.

TAPIMaster® unterstützt ein offensives Telefonieren. Wenn Sie mit dem Kunden sprechen müssen sollten Sie selbst die Initiative ergreifen und nicht auf den Anruf des Kunden warten. Das macht einen besseren Eindruck. Sie sind schneller mit der Arbeit fertig. Sie erledigen die Telefonate am Stück hintereinander und werden nicht bei anderen Arbeiten unterbrochen.

Mit dem ACD Light Modul können Sie eingehende Anrufe gleichmäßig verteilen. Das Modul ist im Kaufpreis enthalten.


Mehr Bedienkomfort

Haben Sie schon einmal mit Ihrem Telefon eine Rufumleitung geschaltet, einen Anruf heran geholt oder eine Konferenz eingeleitet? Kennen Sie die Bedienungsanleitung Ihres Telefons auswendig? Mit TAPIMaster® können Sie Ihr Telefon vom Computer aus bedienen. Gebrauchsanweisungen für Telefon und Telefonanlage gehören der Vergangenheit an. Sie kommen mit weniger Handgriffen ans Ziel. Anstatt Rufnummern abzutippen rufen Sie per Tastenkürzel an.

TAPIMaster® ist bewußt einfach gehalten. Client und Server sind im wahrsten Sinne des Wortes selbst erklärend, auf YouTube gibt es Videos. So finden Sie sich auch ohne Handbuch zurecht.


Mehr Kommunikation

Telefonieren wird einfacher. In der gleichen Zeit werden mehr Telefonate geführt. Gleichzeitig haben Sie beim Telefonieren weniger Stress und können sich auf wesentliche Dinge konzentrieren. Bei eingehenden Anrufen sehen Sie wer anruft und können sich besser auf den Partner einstellen. Die Zusammenarbeit im Team wird durch einfachen Umgang mit den Anrufen erleichtert. In der Firma gibt es weniger Reibungsverluste.


Preisvorteil

Mit diesem Produkt erwerben Sie eine vergleichsweise günstige CTI-Lösung. Bis zu 4 Clients können mit fast allen Funktionen kostenlos benutzt werden. Somit haben Sie als Kunde die Möglichkeit, die Software vor dem Kauf ausgiebig zu testen. Da der Leistungsumfang der Software von der Telefonanlage abhängig ist, können bestimmte Funktionen wie Dreierkonferenz oder Makeln nicht generell zugesichert werden. Prüfen Sie vor dem Kauf ob die Anwendung für Ihre Bedürfnisse ausreicht.


Systemvoraussetzungen

Telefonanlage

·Die Telefonanlage benötigt eine TAPI-Schnittstelle. Informieren Sie sich ggf. bei Ihrem Händler, wenn Sie sich nicht sicher sind.

·Die Telefonanlage ist mit einem PC verbunden. Meist geschieht das über USB oder Netzwerk.

·Die Telefonanlage ist konfiguriert. Anrufe sind möglich.

·Auf dem PC ist der TAPI-Treiber der Telefonanlage installiert und funktioniert. Testen Sie den Treiber mit dem Leitungsbeobachter.

Computerhardware

·PC: 486 oder höher für Server und Client.

·Arbeitsspeicher ca. 5 MB für Server, 8 MB für Client.

·Festplatte: ca. 5 MB für Client, 5 MB für Server + 1 MB pro 10.000 Anrufdatensätze.

·Leistung: Ca. 1 MHz pro Client auf dem Server, bei einem Pentium III 500 MHz also 500 Clients.

Software

TAPIMaster® benötigt Windows 7, Windows 2003 Server oder höher.


Leistungsumfang

Der Funktionsumfang der Software ist abhängig von der jeweiligen Telefonanlage. Deshalb haben Sie vor dem Kauf die Möglichkeit, das Produkt ausgiebig zu testen. So können Sie feststellen, ob der Leistungsumfang Ihren Erwartungen entspricht, bevor Sie Geld ausgeben. Damit Sie sich vor dem Kauf einer Telefonanlage von deren Möglichkeiten ein Bild machen können, liefert Ihnen der Leitungsbeobachter eine Entscheidungshilfe.

Telefoniefunktionen

Programmierschnittstellen

Administratortools

Zusatzfunktionen

Einschränkungen der freien Version


Telefoniefunktionen

·Anwahl und Auflegen von Gesprächen, auch von Zweitanrufen.

·Annehmen von Gesprächen, nützlich bei Headset oder Freisprechschaltung.

·Wahlwiederholung

·Rufumleitung

·Weiterleitung eingehender Gespräche (Call-Deflection)

·Weiterleitung bestehender Gespräche mit und ohne Vorankündigung.

·Rückfragen und Makeln.

·Anzeigen der Rufnummer von eingehenden Anrufen.

·Heranholen von Gesprächen, auch von anklopfenden Anrufen.

·Dreierkonferenz

·Anlagenübergreifende CTI


Programmierschnittstellen

Sowohl auf der Client- als auch auf der Serverseite besteht die Möglichkeit einer Integration in andere Anwendungen. Hierfür stehen jeweils eine C++ und eine COM-Schnittstelle zur Verfügung.

Das TAPIMaster®-Setup lässt sich in ihre Installationen integrieren.

Weiterführende Informationen finden Sie im TAPIMaster® SDK im Internet.


Administratortools

Mit Hilfe der Bedienkonsole des CTI-Servers kann der Administrator die Rechte der Clients festlegen oder mit den Clients operieren.

·Einschränkungen von Rechten der Gruppenmitglieder

·Festlegen von bestimmten Benutzern für ein Telefon

·Versenden von Nachrichten an die Benutzer

·Clients von zentraler Stelle herunterfahren und neu starten

·Clients von zentraler Stelle an anderen Server verweisen

·Separates CTI Switchboard zur Ansicht aller Nebenstellen


Zusatzfunktionen

TAPIMaster® bietet neben der reinen Telefonieunterstützung noch zahlreiche Zusatzfunktionen.

·Anrufvorlagen an andere Benutzer senden.

·Schnellwahl von markiertem Text

·Versenden von Textnachrichten zwischen den Clients.

·Versenden benutzerdefinierter Botschaften zwischen Client und Server.

·Einblenden eines Telefonicons in der Taskleiste analog dem Briefsymbol von Outlook, wenn ein Anruf vorliegt.

·Unterbrochene Verbindungen zum Server werden automatisch wiederhergestellt.

·Tray-Icon in der Taskleiste, welches mit eigenen Icons, Tooltip und Menü versehen werden kann.

·Übermittlung der Protokolldaten (Rufnummer, angerufenen Adresse, Zeit, ein/ausgehend, Erfolg ja/nein, Dauer des Gesprächs) und Speichern der Protokolldaten in einer Datei, Puffern dieser Daten während der Abwesenheit.

·Chatfunktion

·Telefonieren aus anderen Anwendungen möglich

·Optionale Telefonbuchseite mit den Outlook-Kontakten

·Datenbankanbindung (ODBC) für die Rufnummernidentifikation, Suche nach Rufnummern, Speichern von Gesprächsdaten.

·ACD Light zum besseren Verteilen eingehender Anrufe.

·Anruferidentifikation mit Hilfe installierter Telefonbuch-CDs.


Einschränkungen der freien Version

Die nicht lizensierte Version enthält einige Einschränkungen:

·Es sind nur 4 Clients benutzbar.

·Einige Administratorfunktionen (Neustart und Serverwechsel der Clients) sind nicht freigeschaltet.

·Von den 4 angemeldeten Benutzern kann maximal ein Client ein fremder Client sein (Ein eigenständiges Programm welches die Client-Schnittstelle nutzt, z. B. Excel).

·Die Diagnosefunktionen im Server sind nicht freigeschaltet.

·Das temporäre Öffnen von Leitungen für die Anwahl ist deaktiviert.

·Das ACD Light Modul ist nicht Bestandteil der unlizensierten Version.

·Die IP-Schnittstelle des Servers kann nicht genutzt werden.

·Das CTI Switchboard ist nicht verfügbar.

·Das CTI Reporting Tool ist nicht verfügbar.


Installation

Gehen Sie Schritt für Schritt die einzelnen Punkte durch, wenn Sie TAPIMaster® erstmalig installieren.

Bevor es losgeht

Leitungsbeobachter

Installationsprogramm

Server einrichten

Benutzerdefinierte Setups

Sie können benutzerdefinierte Setups erstellen und diese dem Setup Ihrer eigenen Software hinzufügen. Nähere Informationen dazu finden Sie im Programmierhandbuch des CTI-SDKs (PDF-Version).


Bevor es losgeht

Bevor Sie TAPIMaster® installieren vergewissern Sie sich bitte ob Ihr PC über einen geeigneten TAPI-Treiber verfügt und dieser korrekt funktioniert. Öffnen Sie dazu die Telefon- und Modemoptionen in der Systemsteuerung.

Wählen Sie Ihren Standort aus und klicken Sie auf „Bearbeiten". Es erscheint der Dialog für sie Wählregeln. Tragen sie die Vorwahl ein und entfernen Sie die Amtskennziffern aus dem Dialog. Schließen Sie den Dialog mit den Wählregeln.

Schlagen Sie jetzt die Seite "Erweiterte Optionen" in den Telefon- und Modemoptionen auf. In der Liste der installierten TAPI-Treiber sollte Ihre Telefonanlage aufgeführt sein. Meist ist der Hersteller der Telefonanlage im Namen des Treibers enthalten.

Sie finden Ihre Telefonanlage in der Liste. Wenn nicht dann installieren Sie den TAPI-Treiber der Telefonanlage. Die neueste Version des Treibers finden Sie in der Regel auf den Internetseiten des Anlagenherstellers. Installieren Sie auch die neueste Firmware der Telefonanlage. Bei Fragen und Problemen bei der Installation wenden Sie sich bitte an Ihren Anlagenhersteller oder den Händler, bei dem Sie die Telefonanlage erworben haben.

Ist der Treiber installiert, so testen Sie ihn bitte mit dem Leitungsbeobachter um zu sehen ob er funktioniert.


Leitungsbeobachter

Mit dem Leitungsbeobachter können Sie prüfen, ob der TAPI-Treiber funktioniert. Starten Sie das Programm. Wählen Sie ein Telefon aus der Liste mit den Leitungen aus. Telefonieren Sie mit diesem Telefon und lassen Sie sich auf dieser Nummer anrufen. Der Leitungsbeobachter sollte jetzt reagieren und die Liste sich mit Einträgen füllen.

Auf der zweiten Seite können Sie sehen welche Leistungsmerkmale der Treiber unterstützt. Die Angaben sind die des Herstellers. Lassen Sie sich vor dem Kauf der Telefonanlage einen installierten Treiber zeigen, so sehen Sie schnell ob die Leistungen der Anlage Ihren Anforderungen entsprechen. Bestehen Sie auf einem solchen Test, um Fehlkäufe zu vermeiden.

Die dritte Seite "Support Funktionen" sollten Sie nur nach Absprache mit dem Service benutzen.


Installationsprogramm

Die aktuelle Version finden Sie im Internet. Laden Sie das Programm herunter und starten Sie es zuerst auf dem Rechner welcher mit der Telefonanlage verbunden ist. Ein mehrseitiger Dialog führt Sie durch die Installation. Wenn das Installationsprogramm nicht startet prüfen Sie bitte ob ggf. noch andere Telefonieanwendungen aktiv sind und beenden Sie diese.

Startseite

Auswahl Server/Client

Auswahl Anlage und Leitungen

Amtskennziffern und Testnummern

Auswahl Clientkomponenten

Netzwerk / Vorwahl

Zusammenfassung


Startseite

Wählen Sie aus ob Sie TAPIMaster® installieren oder entfernen wollen.


Auswahl Server/Client

TAPIMaster® ist ein C/S basiertes Programm. Der Server hält die Verbindung mit der Telefonanlage. Client und Server können auf dem gleichen Computer installiert sein.

Unter Windows 2003 und seinen Nachfolgesystemen läuft der CTI-Server als Dienst. Der CTI-Server wird beim Rechnerstart automatisch mit gestartet. Sie können den TAPIMaster®-Server auch in der Dienstesteuerung sehen. Der Name des Dienstes kann je nach OEM-Version abweichen. Diensteverwaltung öffnen...

Client ohne Installation starten

Bei der Installation des Servers wird ein Unterverzeichnis "Setup" erzeugt. Geben Sie dieses Verzeichnis im Netzwerk frei. Legen Sie eine Verknüpfung zu der Datei FCTICLNT.EXE auf dem Desktop an. Der Verknüpfungspfad sollte relativ sein so dass er im Netzwerk gültig ist, z. B. \\pdc\c\Programme\Setup\FCTICLNT.EXE. Mailen Sie diese Verknüpfung an die vorgesehenen Benutzer.


Auswahl Anlage und Leitungen

Installieren Sie das Diagnoseprogramm des Servers. Bei der Erstinstallation können Sie zusätzlich die Telefonanlage auswählen. Sofern Sie noch nicht über eine Lizenz verfügen können Sie von der gewünschten Telefonanlage 4 Clients benutzen.


Amtskennziffern und Testnummern

Amtskennziffern

Meist arbeiten die Telefonanlagen ohne spontane Amtsholung. Für Externgespräche ist dann die Wahl einer Amtskennziffer vorab erforderlich. Bei spontaner Amtsholung muss dagegen eine Ziffer bei Interngesprächen vorgewählt werden.

Testrufnummern

Tragen Sie hier eine externe Rufnummer ein welche probeweise angerufen werden kann, idealerweise Ihre Handynummer. Am Ende der Installation werden 4 oder mehr Rufnummern aufgelistet welche Sie verwenden können. Rufen Sie dann von einem dieser Apparate die Testrufnummer an und rufen Sie anschließend genau dieses Telefon zurück. TAPIMaster® findet dann automatisch heraus ob bei ein- und ausgehenden Gesprächen Amtskennziffern herausgefiltert werden müssen.


Auswahl Clientkomponenten

Zum Standardclient können zusätzliche Telefonbücher installiert werden.

Das Outlook-Telefonbuch greift auf lokale oder Exchange-Daten zu. Wenn Sie über Outlook verfügen, sollten Sie dieses Telefonbuch unbedingt installieren, da hierüber auch ein Teil der Rufnummernidentifikation läuft.

Mit der Datenbankanbindung können Sie sich ein Telefonbuch aus Ihrer zentralen Datenbank erstellen. Dazu ist es erforderlich dass Ihr Administrator die Datenbankschnittstelle auf dem TAPIMaster® Server eingerichtet hat. Installieren Sie das Datenbanktelefonbuch nur wenn Sie im Unternehmen eine zentrale Datenbank haben. Fragen Sie Ihren Administrator.

Neben dem Standardclient kann ein deutlich abgespeckter Small Client installiert werden, welcher keine Oberfläche besitzt.


Netzwerk / Vorwahl

Der Server benötigt eine Portnummer. Er öffnet diesen Port beim Start für die Clients. Die Clients benötigen neben der Portnummer noch den Namen oder die IP-Adresse des Servers und ihre eigene Durchwahl. Die Portnummer sollte auf Server und den Clients gleich sein, damit eine Netzwerkverbindung hergestellt werden kann.


Zusammenfassung

Zum Abschluss werden noch einmal die zu installierenden Komponenten aufgelistet. Bestätigen Sie mit "Fertig stellen".


Server einrichten

Nach der Installation des CTI-Servers wird automatisch seine Bedienkonsole angezeigt. Nach der Erstinstallation sehen Sie einen kleinen Hinweisdialog mit wichtigen Informationen.

Die Bedienkonsole

Anlageneinstellungen

Durchwahlen

Gruppenverwaltung

Benutzerverwaltung

TAPI-Sonderbehandlung

Diagnosefunktionen

Datenbankschnittstelle

IP-Schnittstelle

Besonderheiten beim Mehranlagenbetrieb

ACD light


Die Bedienkonsole

Die Bedienkonsole ist ein mehrseitiger Dialog. Gehen Sie Seite für Seite durch und nehmen Sie ggf. Änderungen an den Voreinstellungen vor. Die meisten Parameter sollten aber bereits eingetragen sein.

Die Serverkonsole verfügt über mehrere Registerkarten, welche Sie der Reihe nach durchgehen sollten. Beenden Sie dazu den CTI-Server, falls dieser aktiv sein sollte.


Anlageneinstellungen

Bei der Installation werden viele Einstellungen automatisch vorgenommen. Die Seite "Anlageneinstellungen" könnte nach der Installation etwa so aussehen. Beenden Sie den CTI-Server, wenn Sie hier etwas ändern wollen. Wenn mehrere Anlagen benutzt werden sollen dann beachten Sie bitte die Hinweise hierfür.

Lizenzen

Wenn Sie eine Lizenz erhalten haben, tragen Sie diese bitte hier ein.

Anlagen aktualisieren

Wenn Sie die Anlagen aktualisieren, wird die alte Konfiguration gelöscht und die vorhandenen Telefonanlagen neu eingelesen:

·Die CTI-tauglichen TAPI-Treiber auf dem System werden ermittelt.

·Die maximale Länge der internen Durchwahlen errechnet sich neu aus den eingelesenen Rufnummern.

·Allen Leitungen wird eine Durchwahl zugeordnet, sofern die Durchwahl Bestandteil des Leitungsnamens ist und die Lizenzen dafür reichen.

·Rufumleitungen, Anmeldenamen, Gruppenzugehörigkeit und Exclusivbenutzer werden gelöscht.

·Ebenfalls gelöscht wird die Tabelle mit den TAPI-Sonderbehandlungen.

·Die Gruppennamen bleiben bestehen. Ebenso die Gruppenbeschränkungen für bestimmte Aktionen.

Die Aktualisierung der Anlagen wird notwendig wenn der TAPI-Treiber neu installiert wurde oder eine neue Anlage hinzugekommen ist. Nach der Erstinstallation ist eine Aktualisierung nicht erforderlich.

Liste mit den Anlagen

In der Mitte können Sie sie CTI-tauglichen Geräte sehen, deren TAPI-Treiber installiert ist. Die Anlagen sind namentlich aufgeführt, anhand der Anlagen-ID können Sie zwei gleiche Anlagen unterscheiden. Für die Externwahl kann eine Amtsnummer erforderlich sein, wenn Sie keine automatische Amtsholung in der Anlage eingestellt haben. Andererseits kann bei automatischer Amtsholung eine bestimmte Nummer für die Internwahl erforderlich sein. Bei ein- und ausgehenden Gesprächen wird möglicherweise eine Amtsnull mit übertragen. Die Ziffern die bei einem Externgespräch weggefiltert werden sollen können Sie in den Filtern eintragen. Die eigene Vorwahl wird schon bei der Installation eingetragen. Befindet sich eine Telefonanlage an einem anderen Standort, so ändern Sie die Vorwahl. Bei Anlagenanschlüssen ist die Rufnummer der Anlage erforderlich, z. B. 4567 bei der Nummer +49 (30) 4567-123.

Noch ein Hinweis zur Amtsnummer: Sie können hier zusätzlich zur Amtsnull die Vorwahl eines günstigen Providers (z. B. 010023) eintragen, die komplette Nummer würde dann 0010023 lauten.

Wenn Sie sich nicht sicher sind ob Sie eine Amts- oder Filternummer benötigen, so testen Sie eine Leitung mit dem Leitungsbeobachter. Die Filternummern werden normalerweise automatisch vom Programm eingetragen. Tätigen Sie die beiden Testanrufe nach der Installation. Die Einträge lassen sich mit Tastaturbefehlen bearbeiten:

STRG + A alles auswählen

DEL Auswahl löschen

STRG + D Duplizieren der Daten des ausgewählten Eintrags aus alle Einträge.

Portnummer

Der Port wurde schon bei der Installation eingetragen. Die Voreinstellung ist 2501. Die Portnummer ist bei Server und Clients gleich. Falls 2501 schon belegt sein sollte dann wählen Sie einen Port größer als 1024. Mit Hilfe von "Portinfo" können Sie prüfen ob der Port noch frei ist.

Server starten / Server beenden

Sie können den CTI-Server mit der Serverkonsole bequem starten und beenden. Unter Windows 2003 und seinen Nachfolgeversionen startet der TAPIMaster® Server als Dienst.

Startverzögerung

Wenn der CTI-Server nach dem Einschalten des Rechners nicht arbeitet (z. B. wenn die Clients sich nicht anmelden können) sollten Sie hier eine Zeit von 60 - 120 Sekunden eintragen.

TAPI Server beenden

Es kann vorkommen dass sich der Windows TAPIServer nicht ohne Neustart des Rechners beenden lässt. Diese Option bietet dagegen die Möglichkeit diesen Prozess direkt zu beenden. Die Option ist nur in der Lizenzversion enthalten.

Neustart

Wenn der CTI-Server gelegentlich nach mehreren Tagen oder Wochen plötzlich nicht mehr arbeitet sollten Sie diese Option aktivieren. Das Programm wird dann zu der festgelegten Uhrzeit beendet und neu gestartet.


Durchwahlen

Jeder Leitung ist bei TAPIMaster® eine Interndurchwahl zugeordnet. Bei der Installation versucht das Programm die Nummern zu erkennen. Hat eine Leitung z. B. den Namen CAP 100, dann wird die Durchwahl 100 vermutet. Es werden nur so viele Durchwahlen vergeben wie Lizenzuser vorhanden sind. Die restlichen Zeilen erscheinen grau.

Bei mehreren Telefonanlagen werden die Durchwahlen der Telefonanlage mit den meisten Leistungsmerkmalen verwendet. Wenn die Durchwahlen nicht erkannt werden, so ist erforderlich diese manuell einzutragen.

Bitte entfernen Sie nicht verwendete Leitungen. Leitungen ohne Lizenz werden grau angezeigt.

Die TAPI-Treiber verschiedener Telefonanlagen können durch ihre Anlagen-ID unterschieden werden.

Lizenzen sparen (Nur Lizenzversion)

Sie haben z. B. 50 Telefone. Nur für 20 davon benötigen Sie volle Funktionalität (Rufnummernidentifikation, Rückfrage, Weiterleitung usw.). Aktivieren Sie dazu die Option "Leitung nur bei Anruf öffnen". Klicken Sie jetzt auf "Übernehmen".

Die Leitungsliste bekommt jetzt leere Kästchen auf der linken Seite. Haken Sie die Leitungen an welche über volle Funktionalität verfügen sollen. Diese TAPI-Leitungen werden immer geöffnet. Markieren Sie jedoch nur höchstens eine Leitung weniger als Sie Lizenzen haben. Wenn Sie 25 Lizenzen gekauft haben und 20 fest zuteilen, bleibt noch eine Reserve von 5 Leitungen. Diese 5 Leitungen können die restlichen 30 Benutzer sich für die Anwahl teilen, d. h. die Leitungen werden nur geöffnet wenn ein Anruf erfolgt und danach gleich wieder geschlossen. Die Option "Leitungen nur bei Anruf öffnen" steht nur in der Lizenzversion zur Verfügung.

Die nicht ständig aktiven Leitungen unterliegen einigen Einschränkungen:

·Keine Informationen über eingehenden Anrufe (Rufnummer, Gesprächszustände)

·Anmeldestatus wir nicht übermittelt

·Annehmen von Gesprächen per Software nicht möglich

·Keine Rufumleitung und Umlenkung eingehender Gespräche (Call-Deflection)

·Keine Konferenz

·Die eigenen Gesprächszustände werden bei Gruppenmitgliedern nicht angezeigt.

·Andere Mitarbeiter können von diesen Leitungen keine Gespräche heranholen.

·Die IP-Schnittstelle des Servers kann nicht verwendet werden.

Maximale Länge interner Nummern

Bei der Installation ermittelt TAPIMaster® die maximale Länge der internen Durchwahlen. Das kann fehlschlagen wenn die Durchwahl nicht im Leitungsnamen enthalten ist. Korrigieren Sie die Länge. Anhand der Einstellung entscheidet TAPIMaster® ob der Anruf nach Extern geht.


Gruppenverwaltung

Die Leitungen lassen sich zu Gruppen zusammenfassen. Gruppen können überlappend sein. Die Benutzer können in der Gruppenansicht sehen ob andere Gruppenmitglieder besetzt sind oder gerade angerufen werden.

Gruppenbeschränkungen

Die Durchführbarkeit bestimmter Aktionen lässt sich auf die Mitglieder einer Gruppe beschränken. Auf dieser Seite legen Sie die Namen für die Gruppen und die Beschränkungen fest. Mitglieder der Gruppe "Administrator" unterliegen keinen Beschränkungen.


Benutzerverwaltung

Auf dieser Seite sind alle Leitungen aufgelistet. Am Telefonsymbol links können Sie sehen ob ein Benutzer angemeldet ist oder nicht. Bei angemeldeten Benutzern ist außerdem noch der Anmeldename sichtbar. Sie können die zuletzt geschaltete Rufumleitung sehen und ob diese aktiv ist. Die Gruppen in denen die Leitung beteiligt ist werden aufgelistet. Ist einer Leitung ein Exclusivbenutzer zugeordnet, kann sich nicht jeder Benutzer an diese Leitung anmelden.

Ändern der Leitungseinstellungen

Einstellungen ändern

Gruppen zuordnen

Hilfsfunktionen für den Administrator

Sie können die Hilfsfunktionen nur nutzen wenn der CTI-Server läuft.

Nachricht senden

Server wechseln

Clients neu starten

Rufumleitung aus


Einstellungen ändern

Sie können die Einstellungen für jeden Benutzer einzeln ändern. Per Doppelklick auf die Leitung des Teilnehmers oder Klick auf "Einstellungen ändern" erhalten Sie einen Konfigurationsdialog.

Die Rufumleitung lässt sich nur schalten wenn der CTI-Server läuft.


Gruppen zuordnen

Sollen mehrere Leitungen in eine Gruppe zusammengefasst werden so wählen Sie die betreffenden Leitungen in der Benutzerverwaltung aus und klicken dann auf "Gruppen zuordnen".

Sie können Gruppen hinzufügen oder wieder entfernen. Wird eine Gruppe auf der rechten Seite grau angezeigt, so sind nicht alle in der Benutzerverwaltung ausgewählten Leitungen Mitglied der Gruppe. Benutzer können in mehreren Gruppen gleichzeitig sein. Wer in der Gruppe "Administrator" ist, kann sich beim Telefonieren über bestimmte Beschränkungen hinwegsetzen. Nicht jeder Teilnehmer muss Mitglied einer Gruppe sein.


Nachricht senden

Der Administrator kann Kurznachrichten an die Benutzer senden. Dazu wählt er in der Benutzerverwaltung die entsprechenden Leitungen aus und klickt auf "Nachricht senden".

Es erscheint ein kleiner Dialog mit dem die Nachricht verschickt werden kann. Sollten die Empfänger nicht angemeldet sein, so erhalten sie die Nachricht bei der nächsten Anmeldung.


Server wechseln

Sie können die Clients an einen anderen Server verweisen, wenn z. B. der aktuelle Rechner wegen Wartungsarbeiten heruntergefahren werden soll. Wählen Sie in der Benutzerverwaltung die betreffenden Leitungen aus und klicken Sie auf "Server wechseln". Die Funktion ist nur in der Lizenzversion enthalten.

Die Wiederanmeldung der Clients kann zeitverzögert sein.


Clients neu starten

Wenn Sie die TAPIMaster®-Clients austauschen wollen, können Sie diese für eine gewisse Zeit herunterfahren und danach wieder neu starten. Wählen Sie in der Benutzerverwaltung die betreffenden Leitungen aus und klicken Sie auf "Clients neu starten". Die Funktion ist nur in der Lizenzversion enthalten.

Frühestens nach etwa einer halben Minute erfolgt dann der Neustart. Wenn "Neustart in" nicht aktiviert ist werden die Clients nicht neu gestartet.


Rufumleitung aus

Mitunter kann es vorkommen dass Benutzer vergessen ihre Rufumleitung herauszunehmen. Auch das kann vom Server aus erledigt werden. Der CTI-Server sollte laufen. Wählen Sie in der Benutzerverwaltung die betreffenden Leitungen aus und klicken Sie auf "Rufumleitung aus".

Bestätigen Sie den folgenden Dialog.


TAPI-Sonderbehandlung

Verschiedene Anlagen unterstützen nicht alle Aktionen über die TAPI-Schnittstelle. Dieses Problem lässt sich teilweise umgehen, indem die Tastencodes gesendet werden, die man für den gleichen Befehl am Telefon eingeben würde. Hierzu benötigen Sie das Handbuch der jeweiligen Telefone / Telefonanlagen. Die eigene Durchwahl wird durch A ersetzt, die andere Nummer sofern vorhanden durch B. Testen Sie die Funktionen bevor Sie sie einsetzen.

Eine Garantie gibt es hierfür jedoch nicht, es ist lediglich eine Möglichkeit, die funktionieren kann, also eine Notlösung. Wenn Sie wenige Erfahrung mit Telefonanlagen haben, dann nehmen Sie auf dieser Seite bitte keine Änderungen vor.

Stabilisierungsmechanismen

Die wenigsten TAPI-Treiber sind völlig fehlerfrei. Das Programm versucht einige Fehler im Telefoniesystem selbständig zu beseitigen, u. a. werden Gespräche die nicht mehr existieren entfernt. Schalten Sie diese Option bei großen Anlagen möglichst zu. Es kann versucht werden in der Telefonanlage hängen gebliebene Anrufe aufzulegen.

Rufumleitung in Telefonanlage schalten

Aktivieren Sie die Option. TAPIMaster® versucht dann die geschalteten Rufumleitungen in der Telefonanlage einzurichten. Sollte das nicht funktionieren dann deaktivieren Sie diese Option. Es wird dann versucht eingehende Anrufe an das Ziel weiter zu leiten. Bei der angerufenen Stelle wird es einmal kurz klingeln.

Zwischen verschiedenen Anlagen über Amt kommunizieren

(Nur wenn mehrere Telefonanlagen angebunden sind) Wie werden Nebenstellen in einer anderen Anlage (Filiale) angerufen? Normalerweise wählt man die Ortsvorwahl + Stammrufnummer + Nebenstelle. Dann würde die Option aktiviert werden. Manche Anlagen sind aber auch vernetzt. In diesem Fall bitte deaktivieren. Bei nur einer Telefonanlage (Regelfall) die Option nicht aktivieren.

Zusätzliche Filternummern benutzen

Viele Anlagen arbeiten noch mit LCR. Leider sind nicht alle Telefonanlagen so intelligent die Providervorwahlen bei der Rufnummernsignalisierung herauszufiltern. Geben Sie hier die Providervorwahlen ein die Sie filtern möchten.

Kanonisches Format

Es ist empfehlenswert, die Rufnummern eingehender Gespräche in das kanonische Format umzuwandeln. Wenn Sie die Rufnummern so abspeichern wollen wie sie am Telefon gewählt werden dann deaktivieren Sie diese Option und aktivieren "Eigene Vorwahl entfernen". Wenn die Rufnummern in den Datenbanken ohne Klammern und Leerzeichen stehen dann aktivieren Sie "Einfaches kanonisches Format verwenden".


Diagnosefunktionen

Für Experten

Die Diagnosefunktionen sind nur in der lizenzierten Version enthalten. Mit ihrer Hilfe lässt sich die Dauerstabilität von CTI-Systemen testen. Dabei führt das Programm über einen längeren Zeitraum verschiedene Telefonieaktionen durch. Die Intensität und die durchgeführten Aktionen lassen sich einstellen.

Starten Sie den Test nicht während des normalen Tagesablaufs! Starten Sie den Test nur wenn Sie mit Ihrer Telefonanlage hundertprozentig vertraut sind! Der Test kann einen Neustart der Anlage und des Serverrechners erforderlich machen, falls die Anlage oder der TAPI-Treiber beim Test versagen.

Der Test macht nur Sinn wenn die Telefone ins Freisprechen schalten können, also System- oder unterstützte ISDN. Telefone sind. Die Telefone müssen Gespräche entgegen nehmen können. Das verzögerte Öffnen der Leitungen darf nicht aktiviert sein.

Testablauf

·Tragen Sie zuerst die Zielrufnummern in die Liste ein. Das können auch externe Rufnummern sein, hier fallen dann allerdings entsprechende Gebühren an. Beginnend bei einer Interndurchwahl können Sie die Liste auch automatisch ausfüllen lassen.

·Legen Sie den Umfang der zu testenden Aktionen fest. Beginnen Sie mit "Anrufen" und erweitern Sie die Funktionen Test für Test.

·Starten Sie den CTI-Server.

·Starten Sie den Test beginnend mit einem Intervall von 10000 Millisekunden und erhöhen Sie langsam die Intensität.

Testumfang

Anrufen

Die Nummern in der Liste werden zufällig ausgewählt und angerufen.

Gespräche entgegennehmen

Das Programm nimmt Gespräche an, wenn sie das erste Gespräch in der Leitung sind.

Halten

Ein gerade aktives Gespräch wird gehalten. Es wird nur das erste Gespräch in der Leitung gehalten.

Weiterschalten

Ein Gespräch wird weitergeleitet, ohne vorher angenommen worden zu sein. Die Zielrufnummer ist eine zufällig ausgewählte Testnummer.

Blind Transfer

Ein aktives Gespräch wird ohne Vorankündigung weitervermittelt.

Verbinden

Zwei Gespräche von denen eines aktiv ist werden zusammengeschaltet.

Drop bei Disconnected

Bei einigen wenigen Treibern (z. B. ESP von Microsoft) kann es erforderlich sein diese Option zu schalten. Aktivieren Sie diese wenn die Anrufe im Disconnected hängen bleiben.


Datenbankschnittstelle

TAPIMaster® kann über ODBC an Datenbanken angeschlossen werden. Die Datenbankanbindung dient dabei hauptsächlich der Rufnummernidentifikation und dem Speichern der Gesprächsdaten.

Gesprächsdatensätze an Clients senden

Für jeden Telefonanruf wird ein Gesprächsdatensatz generiert, welcher die Durchwahl des Mitarbeiters, die Nummer des anderen Telefonpartners, Beginn und Ende, die Anrufrichtung und den Verbindungserfolg einschließt. Ist diese Option aktiviert, dann wird nach jedem Gespräch ein Datensatz an den Client geschickt. Während der Abwesenheit eines Clients werden die Daten für ihn gesammelt. Bei der nächsten Anmeldung erhält er dann die Gesprächsdaten.

Einige Telefonanlagen können die Anruferdaten im Display des Telefons zeigen.

Protokollierung der Gesprächsdaten

Die Telefondatensätze lassen sich auch in Textform mit konstanten Zeichenabständen ablegen. Diese können dann schnell in eine Tabellenkalkulation eingelesen werden. Der Eintrag umfasst Datum, Uhrzeit, eigene Durchwahl, andere Rufnummer, Verbunden (ja/nein), Richtung (ein/aus -gehend), Gesprächsdauer in Sekunden, bei eingehenden Anrufen die angerufene Adresse des Telefons sowie die angerufene Nummer (ist bei Gruppenrufen abweichend).

05.01.2002,15:07:39, 10, 061759857482, ja,aus, 31,

07.01.2002,08:29:44, 10, 0892587415,nein,ein, 0, 10, 50,

07.01.2002,08:35:01, 10, 0892587415, ja,aus, 127,

11.01.2002,13:08:25, 10, 20, ja,aus, 603,

Es kann erforderlich sein, dass die protokollierten Daten unkenntlich gemacht werden müssen. Vor dem Speichern werden dann externe Nummern in ihren letzten drei Nummern überschrieben, z. B. so:

07.01.2002,08:35:01, 10, 0892587XXX, ja,aus, 127

Der angemeldete Teilnehmer bekommt jedoch die korrekten Daten übermittelt.

ODBC-Anbindung

Es gibt drei Datenbankverbindungen, welche TAPIMaster® unterhalten kann. Sie können eingehenden Anrufer anhand der Daten identifizieren. Aus diesen Daten können die Clients Telefonbücher erstellen. Die anfallenden Gesprächsdaten können wiederum in eine andere Datenbank geschrieben werden. Als dritte Möglichkeit haben Sie als Programmierer eine Schnittstelle zur freien Verwendung, wodurch Sie in Ihren Clients direkt SQL-Befehle absetzen können.

Wenn Sie die ODBC-Anbindung einrichten, sollten Sie mit SQL und der Einrichtung von ODBC-Datenquellen vertraut sein. Wenn Sie die Anbindung testen wollen, laden Sie sich das TAPIMaster®-SDK herunter, dort ist eine kleine Datenbank enthalten welche in den nachfolgenden Beispielen beschrieben wird.

Wichtig: Die Datenbank versorgt alle Clients mit Anruferinformationen, indirekt sind somit alle Clients mit der Datenbank verbunden. Informieren Sie sich bei Ihrem Datenbankanbieter, ob Ihre Datenbanklizenzen hierfür ausreichend sind.

Die ODBC-Datenquellen müssen Systemdatenquellen sein.

Rufnummernerkennung

Gesprächsdaten speichern

Nachrichten speichern

SQL-Schnittstelle

SQL Tools


Rufnummernerkennung

Klicken Sie auf "Einstellungen". Der Konfigurationsdialog erscheint.

Nach der Erstinstallation ist der Dialog noch leer. Klicken Sie auf "Datenquelle".

Wählen Sie zuerst die Datenquelle aus. Die Angaben in diesem Beispiel beziehen sich auf die Vereinsdatenbank aus dem TAPIMaster®-SDK. Im Beispiel unten wird eine Systemdatenquelle auf Basis der Access-Datei CLUB.MDB aus dem SDK erzeugt und als Datenquelle ausgewählt.

Die Verbindung zur Datenbank steht nun. Legen Sie jetzt die Tabelle fest in denen sich die Kundendaten befinden. Sie können auch Standardtabellen erstellen, welche dann bereits alle notwendigen Datenfelder enthalten.

Bei der Rufnummernidentifikation wird die übermittelte Rufnummer in der Datenbank nachgefragt und ein Datensatz zurückgeliefert. Legen Sie unter der Option "Daten..." fest was in den Clients angezeigt werden soll.

Aus den Angaben wird ein SQL-Abfragetext generiert, welcher vom TAPIMaster® Server an die Datenbank geschickt wird. Sie können diesen Text noch manuell nachbearbeiten, z. B. wenn Sie eine andere Formatierung wünschen. Im Beispiel werden Nachname, Vorname und Rufnummer im Client auf der Anrufseite angezeigt.Da die Datenbankverbindung schon Zugriff auf die Telefondaten hat, kann bei Bedarf auch zu einem Namen die passende Rufnummer gesucht werden. Legen Sie auch hier die Daten fest welche aus der Datenbank geliefert werden.

Auch hier wird eine SQL-Abfrage erstellt, die von Hand nachbearbeitet werden kann. Die gefundenen Informationen werden im Datenbank-Telefonbuch angezeigt.

Die Rufnummernerkennung ist nun aktiviert.


Gesprächsdaten speichern

Für diese Datenbankverbindung ist nur eine Datenbanklizenz erforderlich. Klicken Sie auf "Einstellungen". Der Konfigurationsdialog erscheint.

Nach der Erstinstallation ist der Dialog noch leer. Klicken Sie auf "Datenquelle" und wählen Sie die Datenbankverbindung aus.

Legen Sie danach fest in welche Tabelle die Anruferinformationen gespeichert werden sollen. Sie können auch Standardtabellen erstellen, welche dann bereits alle notwendigen Datenfelder enthalten.

Legen Sie nun fest was und in welche Tabellenspalten die Daten gespeichert werden sollen.

Aus den Angaben wird eine SQL-Anweisung generiert. Diese können Sie manuell nachbearbeiten.

Die Angaben in diesem Beispiel beziehen sich auf die Vereinsdatenbank aus dem TAPIMaster®-SDK. Im Beispiel wird der Zugriff auf eine Access-Datenbank gezeigt. Die gespeicherten Daten haben folgende Formate:

Eigene Durchwahl: Text, mindestens 8 Zeichen

Andere Rufnummer: Text, mindestens 32 Zeichen Nummer des Gesprächspartners

Datum/Uhrzeit: Datumsformat

Gesprächsdauer: Zahl Zeitdauer in Sekunden

Eingehend: BOOL, d. h. Ja/Nein

Verbunden: BOOL, d. h. Ja/Nein

Angerufene Adresse: Text, mindestens 32 Zeichen

Angerufene Nummer: Text, mindestens 32 Zeichen

Call-ID: Eindeutigen Nummer des Anrufs

So werden die Daten in der Tabelle gespeichert:

Die Datenspeicherung über ODBC ist nun aktiviert.


Nachrichten speichern

Es werden Nachrichten zwischen den Benutzern und Rückruferinnerungen gespeichert. Klicken Sie auf "Einstellungen". Der Konfigurationsdialog erscheint.

Nach der Erstinstallation ist der Dialog noch leer. Klicken Sie auf "Datenquelle" und wählen Sie die Datenbankverbindung aus.

Legen Sie danach fest in welche Tabelle die Nachrichten gespeichert werden sollen. Sie können auch Standardtabellen erstellen, welche dann bereits alle notwendigen Datenfelder enthalten.

Legen Sie nun fest was und in welche Tabellenspalten die Daten gespeichert werden sollen.

Aus den Angaben wird eine SQL-Anweisung generiert. Diese können Sie manuell nachbearbeiten.

Die Datenspeicherung ist nun aktiviert.


SQL-Schnittstelle

Sie können eine weitere Datenbank mit ODBC anbinden. Diese Verbindung wird dann an den Client-Programmierschnittstellen zur Verfügung gestellt. Rufen Sie SQL-Befehle direkt aus Ihrem Programm auf. Die Clients benötigen keine direkte Verbindung zur Datenbank. Es werden Texte, Zahlen und boolesche Werte übertragen, also alles was sich als lesbarer Text darstellen lässt. Binärdaten werden nicht unterstützt.

Beachten Sie dazu die Lizenzbestimmungen Ihres Datenbankanbieters.

Klicken Sie auf "Einstellungen". Der Konfigurationsdialog erscheint.

Nach der Erstinstallation ist der Dialog noch leer. Klicken Sie auf "Datenquelle".

Wählen Sie Ihre Datenquelle aus. Sie können bestimmte Schlüsselwörter sperren. Die Antwortpakete können im Text- oder XML-Format kommen. Weitere Informationen finden Sie im Programmierhandbuch des TAPIMaster®-SDKs.

Die Schnittstelle ist nun aktiviert.


SQL Tools

Mit diesem kleinen Programm kann man in Datenbanken nach geeigneten Tabellen suchen, welche sich für eine Rufnummernidentifikation eignen. Das Programm befindet sich auf dem Server im Setup Verzeichnis (C:\<ProgramDir>\<ProductName>\Setup). Die Bedienung ist denkbar einfach:


IP-Schnittstelle

Mit Hilfe der IP-Schnittstelle können Fremdprogramme über das Netzwerk Befehle an den TAPIMaster® Server schicken. Somit können auch Programme auf anderen Plattformen wie Linux TAPIMaster® nutzen. Der Server stellt einen Port zur Verfügung, welcher als Stream- oder Datagramm Socket betrieben werden kann. Ein Programmierbeispiel hierzu befindet sich im SDK. Der Port der IP-Schnittstelle darf nicht mit dem Port des CTI-Servers übereinstimmen.

Folgende Befehle werden unterstützt:

MakeCall

Leitet einen Telefonanruf ein. Syntax MakeCall <Anrufer> <Anrufziel>

Bsp.:

MakeCall 100 0891234567

Der Apparat mit der Durchwahl 100 ruft die Nummer 0891234567 in München an.

Answer

Nimmt einen eingehenden Anruf an.

Bsp.:

Answer 100

Der Apparat mit der Durchwahl 100 nimmt einen Anruf an.

Drop

Das Gespräch wird aufgelegt.

Bsp.:

Drop 100

Der Apparat mit der Durchwahl 100 legt auf.

Redirect

Der Anruf wird umgeleitet

Bsp:

Redirect 100 101

Auf dem Telefon wird der erste eingehende Anruf zum Telefon 101 umgeleitet. Ist kein eingehender Anruf vorhanden, so wird das erste aktive Gespräch zu Telefon 101 übergeben.

Toggle

Wechsel zwischen zwei Anrufen

Bsp:

Toggle 100

Das Telefon 100 makelt zwischen zwei Anrufen.

Transfer

Anrufe verbinden

Bsp:

Transfer 100

Die beiden Gesprächspartner des Telefons 100 werden verbunden.

Conference

Anrufe zu Konferenz zusammenschalten

Bsp:

Conference 100

Die Gesprächspartner des Telefons 100 werden in eine Dreierkonferenz geholt.

Pickup

Gespräch heranholen

Bsp:

Pickup 100 101

Das Telefon 100 holt ein Gespräch vom Apparat 101 heran.

Forward

Rufumleitung schalten

Bsp:

Forward 100 101

Das Telefon 100 leitet Anrufe auf den Apparat 101 um.

Forward 100 *

Das Telefon 100 schaltet Anrufschutz (DND) zu.

Forward 100

Das Telefon 100 hat keine Rufumleitung.

HTTP Aufrufe

Die Anwahl kann auch aus Internetseiten heraus erfolgen. Benutzen Sie dazu den Stream Socket. Fünf große Ns = NNNNN dienen dabei als Platzhalter für die eigene Durchwahl. Adresse und Port des StreamSockets werden mit angegeben.

Beispiele:

<a href="http://localhost:2503/Makecall 100 102">Make a call from extension 100 to 102</a>

<a href="http://localhost:2503/Makecall NNNNN 0123456789">Make a call using IP/Extension table to 0123456789</a>

Die Anfragen kommen so im Server an:

GET /Makecall%20100%20102 HTTP/1.1

GET /Makecall%20NNNNN%200123456789 HTTP/1.1

Im Startverzeichnis befindet sich eine Datei FCTIIPEX.INI. Die Datei wird für die Zuordnung von IP-Adressen zu Durchwahlen verwendet.

Beispiel:

[Extensions]

127.0.0.1=100

192.168.0.101=101

Ein Beispiel finden Sie im Ordner WEBCLIENT im SDK.

Verzeichnis mit Anwahldateien

Wenn sich Befehle nicht als IP-Pakete realisieren lassen können diese auch in Dateien in ein freigegebenes Netzwerkverzeichnis geschrieben werden. Die Dateiendung ist .CTI, die Syntax entspricht der IP-Schnittstelle.


Besonderheiten beim Mehranlagenbetrieb

Bei der Nutzung der Software mit mehreren Telefonanlagen gibt es einige Besonderheiten und Einschränkungen.

·Die Mehranlagenunterstützung gestattet die gemeinsame Benutzung von zwei oder mehreren Telefonanlagen. Die Anlagen müssen sich nicht im selben Ort befinden, es lassen sich mehrere Standorte zusammenführen. Für die Mitarbeiter unterschiedlicher Standorte sieht es so aus, als ob alle an der gleichen Anlage hängen. Bei ortsübergreifenden, vermeintlich internen Anrufen schaltet das Programm selbständig die Vorwahlen und Anlagenrufnummern vor.

·Das Heranholen von Gesprächen aus einem anderen Ort funktioniert nur dann, wenn die Anlage eine Rufweiterleitung nach extern gestattet.

·Für die oben genannten Funktionen werden nur Anlagenanschlüsse unterstützt.

·Die maximale Länge der Durchwahlen orientiert sich an der größeren Anlage.

·In der Leitungsliste dürfen keine Nummern doppelt vergeben sein. Eine 230 z. B. kann zwar auf allen Anlagen existieren, jedoch kann nur eine Nummer davon von der CTI-Software genutzt werden.

·Es wird eine Netzwerkverbindung zwischen den Standorten benötigt. Die Clients brauchen eine Verbindung zum CTI-Server.

·Der Server muss die Telefonanlagen steuern können, auf dem Serverrechner werden TAPI-Treiber für beide Anlagen benötigt, eine Anlage wird dann in der Regel über das Netzwerk angebunden. Für größere Anlagen gibt es Netzwerk-TAPI Anbindungen, bei kleineren Anlagen ist möglicherweise ein Portreplikator die Lösung.

·Eine weniger leistungsfähige Netzwerkverbindung zu den anderen Standorten kann die Arbeitsgeschwindigkeit des Programms herabsetzen.


ACD Light

Das ACD Light Modul ist nur in der Lizenzversion von TAPIMaster® enthalten. Mit dem ACD Light können Sie eingehende Anrufe besser innerhalb Ihrer Servicegruppe verteilen. Es ist eine schlanke und einfach zu administrierende Lösung für ein Inbound Callcenter im Unternehmen. Das ACD Modul verteilt dabei die eingehenden Anrufe sinnvoll auf die vorhandenen Mitarbeiter einer Servicegruppe. Es sorgt dafür dass die Mitarbeiter gleichmäßig ausgelastet werden und genug Pausenzeit zwischen den Anrufen haben. Eine weiter gehende Lösung ist in Planung. Lesen Sie dazu auch das Fallbeispiel ACD Light im Einsatz.

Das ACD-Modul benötigt Telefonanlagen welche ein Redirect (Call Deflection) unterstützt.

Wichtig: Das ACD-Modul beendet alle internen Anrufe auf das Routingtelefon sofort um Fehlbedienungen zu verhindern.

Vorbereitung

Einrichtung

CTI Reporting Tool


Vorbereitung

Öffnen Sie in der Serverkonsole die Benutzerverwaltung. ACD-Funktionen nutzende Teilnehmer müssen in der Servicegruppe sein.

·Schließen Sie ein Telefon an die Anlage an welches ein Redirect unterstützt. Das kann auch ein billiges Analogtelefon sein. Fragen Sie im Zweifelsfall Ihren Anlagenhersteller. Das Telefon sollte sicher vor ungewollter Benutzung sein, der Hörer sollte nicht versehentlich von jemandem abgehoben werden.

·Überlegen Sie wer die Anrufe bekommen soll wenn das ACD keine Anrufe routen konnte, weil z. B. alle Teilnehmer besetzt sind. Das kann die Sekretärin, ein Anrufbeantworter oder auch eine Rufgruppe sein. Das wäre dann der Abwurfplatz.

·Wie wollen Sie die Anrufe auf die Servicekräfte verteilen? Soll jeder etwa gleich viele Anrufe erhalten oder sollen die Mitarbeiter in etwa die gleiche Gesprächszeit haben? Sollen alle Anrufe berücksichtigt werden oder nur die eingehenden Anrufe? Überlegen Sie was für Sie wichtig ist.


Einrichtung

Sie finden die Optionen für das ACD Light Modul in der Bedienkonsole von TAPIMaster®. Sie können es mit wenigen Handgriffen aktivieren.

Routing eingehender Anrufe

Aktivieren Sie die Option "Routing über Telefon mit Durchwahl:". Tragen Sie die Durchwahl de Telefons ein welches die Anrufe weiterleiten soll. Das Telefon muss Redirect (Call Deflection) beherrschen.

Wenn alle Mitarbeiter beschäftigt sind, können Anrufe nicht verteilt werden. Die Anrufe werden dann auf den Abwurfplatz geschickt. Das kann ein Anrufbeantworter, eine Rufgruppe oder die Sekretärin sein.

Allgemeine Routingregeln

Mindestpausenzeit zwischen zwei Anrufen

Zwischen den Anrufen wird den Mitarbeitern eine Mindestpausenzeit eingeräumt, um den letzten Anruf nachbereiten zu können.

Bevorzugt mit letztem Gesprächspartner verbinden

Ruft ein Anrufer wiederholt am gleichen Tag an, so kann er bevorzugt mit seinem letzten Gesprächspartner verbunden werden, falls dieser gerade frei ist und sich angemeldet hat. Diese Option ist empfehlenswert wenn nicht ununterbrochen Anrufe eingehen, der letzte Gesprächspartner also wahrscheinlich gerade frei ist. Die Anruferinformationen werden für einen Tage gespeichert.

Letzten Gesprächspartner der Datenbankregel vorziehen

Hier wird der Anrufer bevorzugt mit dem letzten Gesprächspartner verbunden auch wenn normalerweise ein anderer Mitarbeiter für ihn zuständig ist.

Ergänzende Routingregel

So kann die Arbeit gerechter verteilt werden:

·Geringste Gesamtzeit. Der Mitarbeiter mit der geringsten Gesamtgesprächszeit (Externgespräche ein- und ausgehend) bekommt den Anruf zugewiesen. Empfehlenswert wenn die Telefonate sehr lange dauern, Kundenrückrufe erforderlich sind und die Gespräche einen hohen Anteil an der Wertschöpfung im Unternehmen haben.

·Geringste Zeit eingehend. Der Mitarbeiter mit der geringsten Gesprächszeit für eingehende Externgespräche bekommt den Anruf zugewiesen.

·Geringste Anzahl Gespräche. Es werden Externgespräche ein- und ausgehend berücksichtigt. Ist sinnvoll wenn pro Anruf eine Leistungsvergütung vorgesehen ist und die Anrufzeit vom Mitarbeiter beeinflusst werden kann.

·Geringste Anzahl eingehend. Es werden nur eingehende Externgespräche erfasst.

·Der Mitarbeiter der die längste Zeit kein Externgespräch hatte wird vorgezogen.

Routingregeln aus Datenbank

Sie können für jede eingehende Rufnummer oder Rufnummernblöcke Routingregeln in einer Datenbank hinterlegen. So können Sie sicherstellen dass ein bestimmter Anrufer wenn möglich mit dem passenden Mitarbeiter verbunden wird. So können Sie Anrufe der wichtigsten Kunden mit den kompetentesten Fachleuten verbinden oder Anrufe aus bestimmten Gegenden oder Ländern mit dem Sachbearbeiter welcher die Sprache beherrscht. Legen Sie dazu in Ihrer Datenbank eine Regeltabelle an. Diese hat mindestens zwei Spalten, eine für die Rufnummer im kanonischen Format und eine zweite Spalte für die TAPIMaster®-Anmeldenamen, welche in dieser Reihenfolge kontaktiert werden sollen. Die Namen werden jeweils von einem Semikolon abgeschlossen. Die Anmeldenamen werden in den Netzwerkeinstellungen des Clients festgelegt. Für Anrufe ohne Rufnummernübermittlung existiert ein Eintrag "unknown". Hier ein Beispiel aus dem TAPIMaster®-SDK:

Wenn die Tabelle erstellt ist klicken Sie auf "Datenbankeinstellungen". Bestimmen Sie die Datenquelle. Legen Sie dann die Tabelle und die benutzten Spalten fest. Sie können auch Standardtabellen erstellen, welche dann bereits alle notwendigen Datenfelder enthalten.

Es wird eine SQL-Anweisung generiert, die Sie bei Bedarf nachbearbeiten können.

Sie können die Abfrage individuell gestalten. Der SQL-Dialekt und die Abfragemöglichkeiten können sich bei den verschiedenen Datenbanken unterscheiden. Die Datenbankabfrage ist nun aktiviert.

ACD Daten speichern

Die Anmelde- und Gesprächsdaten der ACD Clients können ebenfalls in Datenbanken gespeichert werden.

ACD Logfiles

ACDLOGLO_XXXX_XX_XX.TXT (Jahr_Monat_Tag)

Logdatei mit den Anmeldedaten der Agents. Format:

Jahr-Monat-TagTStunde-Minute-Sekunde-Milisekunde;Username;Ready;GroupName;Adresse;

Jahr-Milisekunde: UTC Daten.

UserName: Anmeldename.

Ready: 0 oder 1, je nachdem ob sich der Client an- oder abmeldet.

GroupName: Im Server hinterlegte Gruppe des Agents.

Adresse: Durchwahl des Agents bzw. angerufene Adresse.

ACDLOGCA_XXXX_XX_XX.TXT (Jahr_Monat_Tag)

Logdatei mit den Anrufdaten der Agents. Format:

Jahr-Monat-TagTStunde-Minute-Sekunde-Milisekunde;"LASTRESORT";Partner;Adresse;MSN;CallID,"LREXT";0;1;00000000;00000000;(LRGROUP);

Jahr-Milisekunde: UTC Daten.

Partner: Rufnummer des Anrufers, kann leer sein.

Adresse: Angerufene Adresse des Agent Telefons.

MSN: Angerufene MSN.

CallID: Eindeutiger Call Bezeichner.

Restliche Werte: nur für interne Verarbeitung betimmt.


CTI Reporting Tool

Aufgabe

Das CTI Reporting Tool ist ein Datenbetrachter für die informationen welches das ACD Light Modul liefert. Es werden ausschließlich die Daten von Mitgliedern der Servicegruppe ausgewertet. Es gibt verschiedene Ansichten für die Anmeldeinformationen der Servicekräfte und für die Telefonate.

Allgemeines

EXCEL Export

Täglicher Anmeldebericht

Zusammenfassender Anmeldebericht

Tägliche Anrufliste

Zusammenfassende Anrufliste

Agent Anrufliste

Liste der ausgehenden Anrufe

Liste der eingehenden Anrufe


Allgemeines

Das CTI Reporting Tool ist eine MDI Anwendung mit mehreren Datenansichten. Sie können die Ansichten über das Menü oder die Symbolleiste öffnen. Das Programm wird standardmäßig auf dem Server installiert. Sie können es aber auch auf einen anderen Rechner kopieren. In dem Fall ist es notwendig das Arbeitsverzeichnis zu ändern.

Die Datenansichten haben unten mehrere Schaltknöpfe. Sie können einen neuen Zeitbereich auswählen oder die alte Ansicht neu laden. Ein- und ausgehende, verbundene und nicht verbundene sowie interne Anrufe lassen sich ein- und ausblenden. Dadurch ändern sich teilweise die Berechnungsgrundlagen. Alle Spalten sind sortierbar, die Spaltenbreiten und Positionen können geändert werden.

Die Zeiträume für die zusammenfassenden Listen sind frei wählbar. Für die tägliche Auswahl benutzen Sie bitte das linke Datum.


EXCEL Export

Bei Bedarf können einzelne Tabellen oder auch die gesamte Datenbasis im EXCEL-Format gespeichert werden. Beim Export aus einer Tabelle werden nur die markierten Einträge exportiert.


Täglicher Anmeldebericht

Die Mitglieder der Servicegruppe melden sich an um an der Verteilung eingehender Anrufe teilnehmen zu können. Dazu gibt es im Client einen Schalter:

Die Clients werden automatisch abgemeldet wenn der Client geschlossen wird oder sie einen eingehenden Anruf nicht annehmen.

Status

Anmeldung (grün) und Abmeldung (rot).

Name

Anmeldename des Benutzers, meist ist das sein Windows-Anmeldename.

Gruppe

Die erste Gruppe in welcher der Client Mitglied ist.

Datum/Zeit

Zeitpunkt des An- und Abmeldens bzw. der zwangsweisen Abmeldung.


Zusammenfassender Anmeldebericht

Hier sind die Anmeldezeiten der einzelnen Servicemitarbeiter zusammengefasst. Der Zeitraum ist frei wählbar.

Name

Anmeldename des Benutzers, meist ist das sein Windows-Anmeldename.

Gruppe

Die erste Gruppe in welcher der Client Mitglied ist.

Gesamtzeit

Zeit welche der Mitarbeiter im gewählten Zeitraum angemeldet war.


Tägliche Anrufliste

Die Anrufliste listet die Anrufe der Servicegruppe auf. Mittels Filter lassen sich die Anrufe eingrenzen.

Status

Eingehend (Pfeil nach links) oder ausgehend, Verbunden (grün) oder nicht verbunden (rot).

Name

Anmeldename des Servicemitarbeiters, meistens der Windows-Anmeldename.

Gruppe

Die erste Gruppe in welcher der Mitarbeiter Mitglied ist.

Datum/Zeit

Gesprächsbeginn

Durchwahl

Die interne Durchwahl des Servicemitarbeiters.

Anrufpartner

Rufnummer des Gesprächspartners, das wird in der Regel ein Kunde sein.

Zieladresse

Ein Telefon kann verschiedene Adressen haben, z. B: 201, 202, 203. Hinter jeder Adresse kann sich von extern eine andere Hotline verbergen. Mit Hilfe der Zieladresse können die Daten pro Hotline sortiert werden.

Ziel-MSN

Statt einer Zieladresse kann auch die gerufene Nummer ausgewertet werden.

Gesprächszeit

Die Gesprächszeit des verbundenen Anrufs.

Reaktionszeit

Zeit zwischen Anrufbeginn und dem Zustand in dem er verbunden ist, Reaktionszeit des Servicemitarbeiters.


Zusammenfassende Anrufliste

Diese Liste wertet die Gespräche für jeden Servicemitarbeiter für einen frei wählbaren Zeitraum aus. Die Richtung der Anrufe, ihr Verbunden-Zustand und interne Anrufe können selektiert werden. Das hat teilweise Auswirkungen auf die Berechnungen. Blenden Sie bei einem Inbound-Callcenter die ausgehenden und internen Anrufe aus um zu repräsentativen Ergebnissen zu kommen. Verfahren Sie in umgekehrter Weise bei einem Outbound Callcenter.

Name

Anmeldename des Servicemitarbeiters, meistens der Windows-Anmeldename.

Gruppe

Die erste Gruppe in welcher der Mitarbeiter Mitglied ist.

Anzahl Anrufe

Je nach Selektion steht hier die Anzahl der Anrufe in der gewählten Richtung / Verbunden-Status.

Summe Gesprächszeit

Gesamtzeit der Gespräche aller selektierten Anrufe.

Anrufzeit Durchschnitt

Durchschnittliche Zeit der selektierten Anrufe. Nur verbundene Gespräche werden berücksichtigt.

Reaktionszeit Durchschnitt

Durchschnittliche Reaktionszeit in Sekunden.

Unbeantwortet

Anzahl der nicht beantworteten eingehenden Anrufe.

Unbeantwortet %

Prozentualer Anteil der nicht beantworteten Anrufe.


Agent Anrufliste

Diese Ansicht listet alle Anrufe eines Agenten in einem vorher festgelegten Zeitraum auf.

Listenansicht

Status

Eingehend (Pfeil nach links) oder ausgehend, Verbunden (grün) oder nicht verbunden (rot).

Gruppe

Die erste Gruppe in welcher der Mitarbeiter Mitglied ist.

Datum/Zeit

Gesprächsbeginn

Durchwahl

Die interne Durchwahl des Servicemitarbeiters.

Anrufpartner

Rufnummer des Gesprächspartners, das wird in der Regel ein Kunde sein.

Zieladresse

Ein Telefon kann verschiedene Adressen haben, z. B: 201, 202, 203. Hinter jeder Adresse kann sich von extern eine andere Hotline verbergen. Mit Hilfe der Zieladresse können die Daten pro Hotline sortiert werden.

Ziel-MSN

Statt einer Zieladresse kann auch die gerufene Nummer ausgewertet werden.

Gesprächszeit

Die Gesprächszeit des verbundenen Anrufs.

Reaktionszeit

Zeit zwischen Anrufbeginn und dem Zustand in dem er verbunden ist, Reaktionszeit des Servicemitarbeiters.


Liste der ausgehenden Anrufe

Die Anrufliste zeigt die gewählten Rufnummern an. Hieraus ist ersichtlich, welcher Aufwand pro Kunde erforderlich war.

Rufnummer

Die Rufnummer des Kunden.

Anzahl Anrufe

Gesamtzahl der Anrufe zu diesem Kunden, sowohl verbunden als auch nicht verbunden.

Verbundene Anrufe

Anzahl der Anrufe die von dem Kunden beantwortet wurden.

Gesamtzeit

Gesamtgesprächszeit bei ausgehenden Anrufen zu diesem Kunden / dieser Nummer.

Durchschnittliche Gesprächszeit

Durchschnittszeit aller verbundenen ausgehenden Anrufe.


Liste der eingehenden Anrufe

Die Anruferliste zeigt die Rufnummern der anrufenden Kunden an. Hieraus ist ersichtlich, welcher Aufwand pro Kunde erforderlich war.

Rufnummer

Die Rufnummer des Kunden.

Anzahl Anrufe

Gesamtzahl der Anrufe dieses Kunden, sowohl verbunden als auch nicht verbunden.

Verbundene Anrufe

Anzahl der Anrufe bei welchen der Kunden verbunden wurd.

Gesamtzeit

Gesamtgesprächszeit bei eingehenden Anrufen dieses Kunden / dieser Nummer.

Durchschnittliche Gesprächszeit

Durchschnittszeit aller verbundenen eingehenden Anrufe.


Client

TAPIMaster®-Client

Der TAPIMaster®-Client zeigt sich als schmale Leiste am oberen Bildschirmrand. Mit den Schaltern auf der linken Seite kann das Telefon bedient werden, rechts finden Kurzwahlschalter für Gruppenmitglieder platz. Sie können den Client sehen wenn Sie die Maus an den oberen Bildschirmrand bewegen. Er verhält sich etwa so wie die Taskleiste am unteren Rand.

Sie können Ihr Telefon mit diesem Client steuern und sehen die Gesprächszustände Ihrer Kollegen. Zwei Register für Anrufe und Telefonbücher bieten zusätzliche Informationen.

Wenn der Client deaktiviert bleibt und sich auch nach längerer Zeit nicht von selbst anmeldet so überprüfen Sie die Netzwerkeinstellungen.

Small Client

An Stelle des oben gezeigten Standardclients kann ein deutlich abgespeckter Client installiert werden, welcher ohne Oberfläche kommt. Telefonbücher gibt es dort nicht. In diesem können aber ebenso kundenspezifische Plugins geladen werden wie in der Standardversion.

Einstellungen

Anrufregister

Telefonbuchregister

Wie kann ich...


Einstellungen

Zu den Programmeinstellungen / Programminfo kommen Sie über einen Schalter in der Programmleiste. Alternativ können Sie die Einstellungen auch über das Tray Icon des Clients erreichen. Klicken Sie mit der rechten Maustaste auf das Icon und wählen Sie Einstellungen aus dem Menü.

Grundeinstellungen

Erweiterte Einstellungen

Schnellwahl

Netzwerk


Grundeinstellungen

Programminformationen

In den Programminformationen sehen Sie die Produktversion, sie ist wichtig bei eventuellen Rückfragen sowie Angaben zur Lizenz.

Bei eingehenden Anrufen Symbol in der Traybar anzeigen

Microsoft Outlook zeigt für eingehenden Mails ein kleines Briefsymbol in der Traybar an. Der TAPIMaster®-Client kann ein ähnliches Symbol mit einem Telefon nach eingehenden Anrufen anzeigen. Ein Doppelklick auf das Symbol öffnet die Liste eingehender Anrufe.

Eingehende Anrufe automatisch entgegennehmen

Im Servicebereich kann es von Vorteil sein wenn eingehende Anrufe automatisch angenommen werden, um keine Zeit zu verlieren. Dazu sollten die betreffenden Arbeitsplätze über Headsets verfügen und die Telefone per TAPI ins Freisprechen schalten können.

Registerkarten automatisch zuklappen

Wenn Sie außerhalb des Clients auf den Bildschirm klicken klappen die Register nur zu wenn diese nicht manuell aufgeschlagen wurden. Mit dieser Option verschwinden sie immer vom Bildschirm.

Bildschirmeinstellungen

Hier können Sie festlegen auf welchem Bildschirm der Client angezeigt wird.


Erweiterte Einstellungen

Legen Sie hier fest wie sich der Client bei eingehenden Anrufen verhält.

Reaktion bei eingehenden Anrufen

Wenn Anrufe eingehen, dann macht sich der Client normalerweise bemerkbar, indem ein Fenster nach unten klappt und die Anrufdaten anzeigt. Sie können diese Anzeige abschalten. Für einige Kunden mit speziellen Zusatzmodulen gibt es noch eine kundenspezifische Anzeige.

Programm starten

Es ist möglich bei eingehenden Anrufen ein Programm zu starten. Das Programm kann mit kompletten Pfad oder als Befehl (z. B. iexplore) eingegeben werden. Als Parameter wird die Rufnummer übergeben. Die kann auch in einer URL sein, z. B: http://webserver/kunden?Number=<#N#>.

Was tun, wenn jemand aus der Gruppe angerufen wird

Stellen Sie sich vor, jemand aus Ihrer Gruppe bekommt einen Anruf. Der Mitarbeiter geht jedoch nicht ans Telefon weil er gerade abwesend ist oder schon ein Gespräch hat. Sie hören es nicht klingeln weil das Telefon in einem anderen Raum steht. Der Client kann in solch einem Fall die Gruppenansicht herunterklappen, Sie sehen dann wer aus Ihrer Gruppe einen Anruf bekommt. Entscheiden Sie, ob Sie diese Anrufe nicht, sofort oder nur dann sehen wollen, wenn der andere Kollege den Anruf nach X Sekunden nicht entgegen nimmt.

Leitung zurücksetzen

In seltenen Fällen kann es passieren dass ein Client nicht mehr auf das Telefon reagiert. Gespräche werden nicht entfernt und bleiben „hängen". In diesem Fall können Sie „Leitung zurücksetzen" drücken.


Schnellwahl

Sie können Text in verschiedenen Dokumenten oder Webseiten markieren und die darin enthaltene Rufnummer per Tastenkürzel anrufen.


Netzwerk

Wenn Sie den TAPIMaster®-Client erstmalig starten werden normalerweise die Netzwerkeinstellungen automatisch angezeigt. Sie tragen dann Ihre Interndurchwahl ein und werden damit einem Telefon zugeordnet.

Sie können den Netzwerkdialog auch jederzeit anzeigen: Klicken Sie mit der rechten Maustaste auf das Verbindungsicon des Clients und Wählen Sie "Netzwerkverbindung" aus dem Kontextmenü.

Im folgenden Dialog können Einstellungen für Netzwerk und Anmeldung eingestellt werden. Ändern sie Servername und Portnummer nur wenn Ihr Administrator dazu auffordert. Wenn Ihre Durchwahl fehlt oder sich geändert hat ändern Sie diese. Sie können einen Anmeldenamen frei wählen, mit dem Sie bei den Gruppenmitgliedern angezeigt werden. Vorgabe ist hier der Windows-Anmeldename. Meist ist die Amtskennziffer eine "0". Die Amtsholung kann aber auch unterschiedlich sein z. B. wenn sich zwei Firmen eine Anlage teilen. Bei automatischer Amtsholung kann für Interngespräche eine Vorwahlziffer notwendig sein. Diese wird normalerweise ebenso zentral eingestellt wie die Amtskennziffer. Bei einigen Firmen gibt es für Privatgespräche eigene Amtskennziffern.

Wichtig: Verwenden Sie bitte keine abweichenden Amtskennziffern und Internvorwahlen, wenn Sie Ihr Administrator nicht dazu auffordert hier etwas einzutragen.


Anrufregister

Sie finden das Anrufregister auf der linken Seite. Hier finden Sie auch die Telefonlisten und Kommunikationsmöglichkeiten mit den Mitgliedern Ihrer Gruppe.

Anrufen

Eingehend

Ausgehend

Favoriten

Nachrichten

Chat


Anrufen

Mit der Anrufseite können Sie Anrufe starten und die aktuellen Gespräche steuern. Oben werden die Daten des Anrufers angezeigt. In der Mitte sehen Sie die Aktionsschalter. Ganz unten werden Gesprächstasten oder Dialoge eingeblendet.

Anruf für:

Hier wird die angerufene Adresse eingeblendet. Ihr Telefon könnte unter verschiedenen Durchwahlen erreichbar sein. Eine Durchwahl wäre z. B. für die Hotline für Produkt A, die nächste Durchwahl für Produkt B. Leider sind Zahlen nicht besonders aussagekräftig. Hinterlegen Sie deshalb die Interndurchwahlen im privaten Telefonbuch und ordnen Sie die passenden Namen zu unter denen Sie sich beim Kunden melden.

Beim nächsten Anruf sehen Sie dann die Firma welche angerufen wurde. Die Übermittlung der angerufenen Adresse wird nicht von allen Telefonanlagen zur Verfügung gestellt.

Aktionsschalter

Anrufen

Mit dem Schalter erhalten Sie einen Anrufdialog eingeblendet. Sie können die Rufnummer per Maus wählen, manuell eingeben oder in die verschiedenen Telefonbücher wechseln.

Wiederholung

Rufen Sie die zuletzt gewählte Nummer noch einmal an.

Rückfrage

Die Rückfrage blendet den Anrufdialog wie oben gezeigt ein. Tätigen Sie einfach eine zweite Anwahl, der bisherige Telefonpartner wird gehalten. Nicht alle Anlagen unterstützen Rückfrage per TAPI.

Auflegen

Mit einem Klick auf die Taste wird das gerade aktive Gespräch aufgelegt. Sie können auch eine Gesprächstaste per Drag&Drop hier ablegen.

Weiterleiten

Der Schalter leitet das aktive Gespräch zu einer anderen internen oder externen Nummer weiter. Sie können auch ein ankommendes oder inaktives Gespräch weiterleiten, indem Sie die Gesprächstaste per Drag&Drop auf den Weiterleiten-Schalter ziehen. Nicht alle Anlagen unterstützen das Merkmal, insbesondere das Weiterleiten von anklopfenden Gesprächen wird selten unterstützt.

Verbinden

Sie können zwei Anrufer miteinander verbinden, wenn ein Gespräch aktiv und das Andere gehalten ist. Klicken Sie auf den Schalter und es erscheint ein kleiner Dialog. Sie können auch eine Gesprächstaste auf den Verbinden-Schalter ziehen. Nicht alle Anlagen unterstützen dieses Merkmal. Suchen Sie ein Gespräch aus der Liste aus mit dem verbunden werden soll.

Erinnerung

Sie nehmen ein Gespräch für einen Kollegen an der gerade nicht da ist. Der Kunde äußert seine Wünsche und Sie wollen dem Kollegen eine Mitteilung darüber zukommen lassen. Drücken Sie auf Erinnerung oder ziehen Sie das Gespräch auf diese Taste. Es erscheint ein Dialog in dem Sie die Rufnummer für die Rückwahl, die Durchwahl des Benutzers und Ihr Anliegen eingeben können. Der abwesende Benutzer bekommt dann eine Nachricht.

Konferenz

Sie können ein aktives und ein gehaltenes Gespräch zu einer Konferenz zusammenschalten. Oder Sie holen in ein aktives Gespräch / Konferenz einen weiteren Partner hinzu. Konferenzen werden nur von wenigen Anlagenherstellern zuverlässig unterstützt.

Schalten Sie ein aktives und ein gehaltenes Gespräch zu einer Konferenz zusammen indem Sie die Gesprächstaste des gehaltenen Anrufs auf den Konferenzschalter ziehen.

Holen Sie einen zusätzlichen Partner in ein aktives Gespräch oder eine Konferenz indem Sie auf den Konferenzschalter klicken. Der Anwahldialog wird eingeblendet, und Sie können die Nummer des neuen Telefonpartners eingeben oder aus einem der Telefonbücher wählen.

Lösen Sie die Konferenz auf indem Sie die Gesprächstaste des Teilnehmers den Sie aus der Konferenz entfernen möchten per Drag&Drop auf die Auflegen-Taste ziehen.

Nicht bei allen Anlagen lassen sich Konferenzen mit mehr als drei Teilnehmern schalten, die Teilnehmer lassen sich oft nicht in der gewünschten Reihenfolge entfernen.

Gesprächstasten

Jeder Anruf hat eine Gesprächstaste. Sie können sehen ob das Gespräch ein- oder ausgehend ist. Wenn die Anruferidentifikation geklappt hat sehen Sie den Namen des Gesprächspartners, ansonsten seine Rufnummer sofern übermittelt. Aktive Gespräche sind niedergedrückt dargestellt.

Sie können die Gesprächstasten per Drag&Drop auf Aktionsschalter, andere Gesprächstasten, den Desktop oder Telefonbücher je nach Situation ziehen. Genauere Informationen finden Sie dazu auch im Kapitel Wie kann ich.... Wenn Sie mit der rechten Maustaste auf eine Gesprächstaste drücken erscheint ein Kontextmenü. Je nach Situation können einige Menüeinträge deaktiviert sein.

Das Kontextmenü ist eine Alternative zu den Aktionsschaltern. Hier haben Sie zusätzlich noch die Möglichkeit Verknüpfungen auf dem Desktop zu erstellen oder die Gesprächsdaten in Ihr privates Telefonbuch zu importieren.


Eingehend

Sie sehen die eingehenden Telefonate. Wo eine Anruferidentifizierung möglich war erscheint diese unter "Bemerkung". Nicht erfolgreiche Anrufe werden mit rotem Symbol dargestellt. Neben Anrufen finden Sie hier auch Anruferinnerungen von Kollegen.

Per Doppelklick kann der Anrufer zurückgerufen werden (Spalte Uhrzeit und Rufnummer). Mit STRG + C kopieren Sie die ausgewählte Rufnummer in die Zwischenablage. Mit einem Doppelklick auf die Spalte "Bemerkung" kann der Text dort geändert werden. Hilfreich für Kurznotizen zum Anruf.

Über ein Kontextmenü stehen weitere Möglichkeiten zu Verfügung. Wählen Sie einen Eintrag aus und klicken Sie mit der rechten Maustaste darauf.

Sie können den Anrufer ins private Telefonbuch übernehmen oder eine Verknüpfung auf dem Desktop erstellen. Die Anruferliste lässt sich als Textdatei speichern.


Ausgehend

Für die ausgehenden Telefonate existiert ebenfalls eine Liste. Erfolgreiche Telefonate sind grün, nicht erfolgreiche Anrufe mit rotem Symbol dargestellt.

Per Doppelklick kann der Anrufer zurückgerufen werden (Spalte Uhrzeit und Rufnummer). Mit STRG + C kopieren Sie die ausgewählte Rufnummer in die Zwischenablage. Mit einem Doppelklick auf die Spalte "Bemerkung" kann der Text dort geändert werden. Hilfreich für Kurznotizen zum Anruf.

Über ein Kontextmenü stehen weitere Möglichkeiten zu Verfügung. Wählen Sie einen Eintrag aus und klicken Sie mit der rechten Maustaste darauf.

Sie können den Anrufer ins private Telefonbuch übernehmen oder eine Verknüpfung auf dem Desktop erstellen. Die Anruferliste lässt sich als Textdatei speichern.


Favoriten

Die häufigsten erfolgreichen Telefonate finden Sie in der Favoritenliste. Diese können wie üblich per Doppelklick angerufen werden. Mit STRG + C kopieren Sie die Rufnummer in die Zwischenablage. Interne Rufnummern werden hier nicht vermerkt.


Nachrichten

Die Benutzer von TAPIMaster® können sich untereinander Textnachrichten schicken. In einer Liste können Sie die eingegangenen Nachrichten sehen, im Feld darunter den Text in voller Länge. Wollen Sie Nachrichten versenden dann schreiben Sie diese in das unterste Textfeld. Im Feld "Nachricht an" tragen Sie die Durchwahl des Empfängers ein. Ist der andere Kollege nicht angemeldet wird die Nachricht zwischengespeichert und er erhält sie bei der nächsten Anmeldung. Um eine Nachricht an alle Gruppenmitglieder zu senden tragen Sie im Eingabefeld "Nachricht an:" ein * ein.


Chat

Mit angemeldeten Benutzern können Sie chatten. Geben Sie die Durchwahl unter "Chat mit" ein und klicken Sie auf "Start". Alternativ können Sie auch aus der Gruppenansicht ein Mitglied per Drag&Drop auf das Eingabefeld ziehen.


Telefonbuchregister

Das Telefonbuchregister befindet sich auf der rechten Seite. Das Outlook- und das Datenbank-Telefonbuch ist optional, also nicht bei jeder Installation vorhanden.

Privates Telefonbuch

Gruppenansicht

Outlook-Telefonbuch

Datenbank-Telefonbuch


Privates Telefonbuch

Das private Telefonbuch steht nur Ihnen zur Verfügung und wird auch nur lokal gespeichert. Sie können Einträge in die Liste hinzufügen oder von dort löschen. Per Doppelklick auf einen Eintrag wird die hinterlegte Nummer angerufen.

Per Kontextmenü stehen Ihnen noch mehr Möglichkeiten zur Verfügung. Sie können Verknüpfungen auf dem Desktop erstellen, das Telefonbuch als Sicherungskopie laden und speichern und aus anderen Textdateien Telefonbücher importieren und dahin speichern.

Import von Telefonbüchern

Legen Sie zuerst die Datei fest aus der ein Import stattfinden soll. Der Text in dieser Datei sollte pro Zeile einen Datensatz enthalten und die Felder mit Trennzeichen separiert sein. Tragen Sie die Position der Textfelder und den Separator ein. Jetzt können Sie die Daten importieren.


Gruppenansicht

Als Benutzer von TAPIMaster® können Sie Mitglied in einer oder mehreren Gruppen sein. Wenn neben der Durchwahl kein Name steht dann hat der Benutzer sich noch nie angemeldet. Die Namen pflegen sich automatisch ein. Die Gesprächszustände der anderen Gruppenmitglieder werden angezeigt.

Per Doppelklick auf ein Symbol rufen Sie das Gruppenmitglied an. Sie können über ein Kontextmenü weitere Optionen erreichen.

Anrufe und Nachrichten können jederzeit gestartet werden, Chat nur wenn der Partner angemeldet ist. Es ist möglich auf einen Partner eine Rufumleitung zu schalten. Zur besseren Sicht kann das Symbol in die Titelleiste kopiert oder eine Verknüpfung auf dem Desktop angelegt werden. Der Inhalt der Zwischenablage lässt sich als Nachricht an ein Gruppenmitglied schicken.


Outlook-Telefonbuch

Wenn Sie Microsoft Outlook benutzen und das zugehörige Telefonbuch mitinstalliert haben steht Ihnen diese Ansicht zur Verfügung. Es erscheinen nur die Kontakte bei denen auch mindestens eine Rufnummer hinterlegt ist. Per Doppelklick können Sie Ihre Gesprächspartner anwählen. Da Outlook wie alle anderen Telefonbücher auch für die Rufnummernidentifikation herangezogen wird ziehen Sie aus diesem Telefonbuch doppelten Nutzen. Es können mehrere Ordner angezeigt werden, z. B. der private Ordner und Exchange Ordner. Sie können nach Namen oder Rufnummern suchen. Wenn Sie lieber mit Listen arbeiten steht Ihnen natürlich auch diese Möglichkeit zur Verfügung.


Datenbank-Telefonbuch

Wenn der Administrator eine Datenbankverbindung eingerichtet hat steht Ihnen dieses Telefonbuch zur Verfügung. Wie gewohnt ist eine Anwahl per Doppelklick möglich. Sie können nach Namen suchen indem Sie die ersten Buchstaben eingeben und dann auf "Suchen" klicken. Wollen Sie ein komplettes Telefonbuch aus Ihren Datenbeständen aufbauen, so lassen Sie das Suchfeld leer und starten die Suche. Das Datenbank-Telefonbuch wird lokal zwischengespeichert und steht Ihnen beim nächsten Start des TAPIMaster® Clients wieder zur Verfügung.


Wie kann ich...

Beschreibung der wichtigsten Aktionen

Die unten beschriebenen Aktionen sind nicht mit jeder Telefonanlage durchführbar.

ACD Light benutzen

Amtskennziffern ändern

Anrufen

Anrufe auflegen

Anrufe annehmen

Anrufe halten

Anrufe heranholen

Anrufe verbinden

Anrufe weiterleiten

Anrufinformationen weiterleiten

Chatten

Datenbanken nutzen

Durchwahl ändern

Einstellungen ändern

Fehler melden

Gesprächszustände erkennen

Gruppenmitglieder unterstützen

Gruppentasten anlegen

Konferenzen einleiten

Kurzwahltasten auf dem Desktop anlegen

Makeln

Markierten Text anwählen

Nachrichten versenden

Netzwerkeinstellungen ändern

Ohne herunterklappende Dialoge arbeiten

Privatgespräche führen

Programm deinstallieren

Reaktionen auf Anrufe festlegen

Registerkarten automatisch zuklappen

Rückfragen tätigen

Rufnummern in das private Telefonbuch übernehmen

Rufumleitungen schalten

Sehen, ob während der Abwesenheit angerufen wurde

TAPI zurücksetzen

Telefonbücher importieren

Wahlwiederholungen tätigen

Zwischenablage senden


ACD Light benutzen

Das ACD-Modul auf dem Server sollte eingerichtet sein. Drücken Sie im Client die ACD Taste, um als Client gegenüber dem ACD Bereitschaft zum Empfang eingehende Anrufe anzuzeigen.


Amtskennziffern ändern

Die Amtskennziffern und Internvorwahlen werden vom Administrator für die gesamte Telefonanlage festgelegt. Normalerweise brauchen Sie hier als Benutzer nichts ändern. Wenn Sie allerdings abweichende Amtskennziffern oder Interndurchwahlen benutzen sind einige Umstellungen notwendig. Klicken Sie mit der rechten Maustaste auf das Verbindungssymbol des Clients. Wählen Sie "Netzwerkverbindung" aus dem Kontextmenü. So kommen Sie in den Netzwerkdialog, in dem alle notwendigen Verbindungsdaten eingetragen werden.

Abweichende Amtskennziffer

Tragen Sie die Kennziffer ein. Wenn auf dem TAPIMaster®-Server eine Amtskennziffer für alle Teilnehmer festgelegt ist und nur Sie automatische Amtsholung haben dann setzen Sie das Häkchen und lassen das Eingabefeld leer.

Abweichende Internvorwahl

Bei automatischer Amtsholung ist oft eine voran gestellte Ziffer für Interngespräche erforderlich. Wenn Ihre Internvorwahl von den zentralen Einstellungen abweicht, können Sie eine andere Ziffer eintragen. Wenn Ihr Telefon im Gegensatz zu den anderen Apparaten keine Internvorwahl benötigt lassen Sie das Eingabefeld leer.


Anrufen

Anrufdialog

Sie können im Anrufdialog auf "Anrufen" klicken und dann die Nummer eingeben.

Gesprächslisten

Schlagen Sie die Gesprächslisten für eingehende oder ausgehende Anrufe auf und tätigen Sie einen Doppelklick auf den passenden Eintrag. Nutzen Sie die Favoritenliste für Gesprächspartner mit denen Sie häufig sprechen.

Kurzwahlen auf dem Desktop

Wenn Sie Kurzwahltasten auf dem Desktop angelegt haben können Sie den Gesprächspartner durch einen Doppelklick auf diese anrufen.

Gruppentasten in der Programmleiste

Wenn Sie Gruppentasten in der Programmleiste angelegt haben können Sie die Gruppenmitglieder per Mausklick anrufen.

Telefonbücher

Schlagen Sie das Telefonbuch auf in dem sich der Gesprächspartner befindet. Mit einem Doppelklick auf den Eintrag können Sie anrufen.

Markierten Text anrufen

Vergewissern Sie sich, dass in den Einstellungen zur Schnellwahl die Anwahl per Tastenkürzel aktiviert ist. Markieren Sie nun die Rufnummer die Sie anrufen wollen. Drücken Sie das vereinbarte Tastenkürzel (Voreinstellung STRG + F12).


Anrufe auflegen

Schalter "Auflegen" in der Programmleiste

In der Programmleiste befindet sich ein kleiner Schalter. Er legt das erste aktive Gespräch auf, sollte es keine aktiven Gespräche geben wird das erste gehaltene oder ankommende Gespräch aufgelegt.

Schalter "Auflegen" auf der Anrufseite

Auf der Seite "Anrufen" gibt es einen Schalter zum Auflegen von Gesprächen, der das erste aktive Gespräch beendet.

Gesprächstaste auf Schalter "Auflegen" ziehen

Ziehen Sie die Gesprächstaste des Anrufs der aufgelegt werden soll auf eine der beiden Auflegetasten.

Kontextmenü der Gesprächstaste

Klicken Sie mit der rechten Maustaste auf die Gesprächstaste. Über ein Menü können Sie den Anruf auflegen.

Mit Tastenkürzeln auflegen

Wenn Sie in den Einstellungen zur Schnellwahl das Verwenden von Tastenkürzeln aktiviert haben so können Sie Gespräche auch per Tastendruck auflegen. Voreinstellung ist STRG + F11.


Anrufe annehmen

Taste in der Programmleiste

In der Programmleiste gibt es eine Taste mit der Sie eingehende Gespräche annehmen können.

Klick auf Gesprächstaste

Für jeden Anruf gibt es auf der Seite "Anrufen" eine Gesprächstaste. Wenn Sie bei eingehenden Anrufen auf diese Taste klicken, wird der Anruf angenommen.

Kontextmenü der Gesprächstaste

Klicken Sie mit der rechten Maustaste auf die Gesprächstaste. Über ein Menü können Sie den Anruf annehmen.

Tastenkürzel

Wenn Sie in den Einstellungen zur Schnellwahl das Verwenden von Tastenkürzeln aktiviert haben so können Sie Gespräche auch per Tastendruck annehmen, und zwar mit dem gleichen Kürzel wie für die Anwahl. Voreinstellung ist STRG + F12.


Anrufe halten

Gesprächstaste anklicken

Sie können ein verbundenes Gespräch halten wenn Sie dessen Gesprächstaste anklicken. Die Taste rastet dann aus. Bei nochmaligem Klick rastet die Taste wieder ein und das Gespräch ist wieder verbunden.

Kontextmenü der Gesprächstaste

Klicken Sie mit der rechten Maustaste auf die Gesprächstaste. Über ein Menü können Sie das Gespräch halten oder zurückholen.


Anrufe heranholen

Ein Anruf für einen Kollegen kommt an. Dieser ist jedoch abwesend. Der Anruf soll herangeholt werden.

Gruppentaste in Programmleiste

Die Gruppentaste des Kollegen ist violett eingefärbt. Klicken Sie darauf, um das Gespräch heranzuholen.

Symbol in Gruppenansicht

Wenn Sie die Gruppenansicht aufklappen (sofern nicht automatisch geschehen) sehen Sie das Symbol des Kollegen, welches jetzt violett umrahmt ist. Ein Doppelklick darauf holt das Gespräch heran.


Anrufe verbinden

Gesprächstasten verschieben

Sie wollen zwei Teilnehmer miteinander verbinden. Ein Gespräch ist aktiv und der andere Anruf wird von Ihnen gehalten. Auf der Anrufseite sind jetzt zwei Gesprächstasten zu sehen, eine davon ist niedergedrückt. Um die Teilnehmer zu verbinden schieben Sie einfach eine Taste auf die Andere.

Aktionsschalter der Anrufseite

Auf der Anrufseite befindet sich ein Schalter "Verbinden". Klicken Sie darauf. Es wird eine Liste mit Gesprächspartnern eingeblendet. Suchen Sie den Anruf aus der mit dem aktiven Gespräch verbunden werden soll und bestätigen Sie.

Kontextmenü der Gesprächstasten

Klicken Sie mit der rechten Maustaste auf eine der Gesprächstasten. Es erscheint ein Kontextmenü aus dem Sie "Verbinden" auswählen. Es erscheint der Verbindungsdialog wie oben.


Anrufe weiterleiten

Sie können eingehende und verbundene Anrufe weiterleiten. Für die Bedienung des Programms macht das keinen Unterschied.

Programmleiste

In der Programmleiste gibt es eine Taste für das Annehmen von Gesprächen. Diese ist bei eingehenden Gesprächen aktiviert. Würden Sie darauf klicken so wären Sie verbunden. Stattdessen können Sie diese Taste auch per Drag&Drop auf andere Objekte ziehen. Das kann eine Gruppentaste, ein Eintrag im privaten Telefonbuch oder ein Symbol in der Gruppenansicht sein.

Gesprächstasten

Die Gesprächstasten auf der Anrufseite können ebenfalls auf andere Ziele gezogen werden. Eingehende und verbundene Gespräche können weitergeleitet werden.


Anrufinformationen weiterleiten

Sie haben einen Anruf angenommen der nicht für Sie bestimmt war und möchten dem eigentlichen Empfänger davon unterrichten. Dieser ist jedoch abwesend und hält nichts von Mail und gelben Zetteln. Klicken Sie einfach auf den Schalter "Erinnerung" auf der Anrufseite. Im folgenden Dialog können Sie dem Kollegen eine Nachricht zukommen lassen.

Diese landet direkt in seiner Liste mit eingehenden Anrufen so dass er per Doppelklick zurückrufen kann.


Chatten

Verschiedene Möglichkeiten

Öffnen Sie den Chatdialog. Tragen Sie unter "Chat mit" die Durchwahl des Partners ein und klicken Sie auf "Start". Alternativ kann auch ein Partnersymbol aus der Titelleiste oder der Gruppenansicht auf das Feld "Chat mit" gezogen werden. In der Gruppenansicht kann Chat über ein Kontextmenü eröffnet werden. Der Chatpartner muss natürlich angemeldet sein.


Datenbanken nutzen

Erkundigen Sie sich bei Ihrem Administrator, ob eine Datenbankverbindung für TAPIMaster® eingerichtet wurde. Sie sollten bei Ihrem Client das Datenbank-Telefonbuch mitinstalliert haben. Wenn ja sehen Sie dessen Registerkarte auf der Telefonbuchseite.

Sie können nach Namen und Rufnummern in der Datenbank suchen und sich diese im Telefonbuch auflisten lassen.

Wenn Sie das Eingabefeld bei der Suche leer lassen wird ein komplettes Telefonbuch aus der Datenbank erstellt. Das Telefonbuch wird lokal gepuffert, beim nächsten Start des Clients muss es nicht abgerufen werden.


Durchwahl ändern

Klicken Sie mit der rechten Maustaste auf das Verbindungsicon des Clients und Wählen Sie "Netzwerkverbindung" aus dem Kontextmenü. Es erscheint der Verbindungsdialog. Geben Sie Ihre neue Durchwahl ein und bestätigen Sie mit OK.


Einstellungen ändern

Klicken Sie auf das betreffende Symbol in der Programmleiste. Im Dialog finden Sie Informationen und Einstellungen.


Fehler melden

Wenn Sie Fehler im Produkt feststellen so informieren Sie uns bitte unter info@tapimaster.de. In der Regel werden Fehler innerhalb von 48 Stunden behoben. Um Rückfragen zu vermeiden werden folgende Informationen benötigt:

·Betriebssystem-Version des Clients und Servers

·Outlook-Version wenn installiert

·Verwendete Datenbank sofern benutzt

·Hersteller und Typ der Telefonanlage

·Verwendete Version von TAPIMaster®

·Möglichst eine nachvollziehbare Fehlerbeschreibung, ggf. mit Bildschirmkopien.


Gesprächszustände erkennen

Sie bekommen die Gesprächszustände der Mitglieder Ihrer Gruppe(n) angezeigt. Diese können Sie in der Programmleiste oder der Gruppenansicht sehen.

Zustand | Programmleiste | Gruppenansicht
Angemeldet ohne Anrufe |  |
Abgemeldet ohne Anrufe |  |
Besetzt |  |
Eingehendes Gespräch |  |
Anklopfendes Gespräch |  |


Gruppenmitglieder unterstützen

Kollegen, welche gegenseitig Gespräche heranholen wollen sollten in einer Gruppe sein. Gruppenzugehörigkeiten können sich überschneiden. Schlagen Sie jetzt die Erweiterte Einstellungen auf. Legen Sie fest nach wie viel Sekunden die Gruppenansicht aufgeschlagen wird, falls der Kollege den Anruf nicht annimmt. Das geschieht dann auch bei anklopfenden Anrufen. Sie haben dann die Möglichkeit das Gespräch heranzuholen.


Gruppentasten anlegen

Schlagen Sie die Gruppenansicht auf. Ziehen Sie ein Symbol per Drag&Drop auf die Programmleiste und legen es dort ab. Sie können Gruppentasten entfernen indem Sie diese von der Programmleiste herunter ziehen und außerhalb des Clients ablegen.


Konferenzen einleiten

Zwei Gespräche zu Konferenz verbinden

Sie können zwei Gespräche zu einer Dreierkonferenz zusammenfügen. Ein Gespräch sollte verbunden und der andere Anruf gehalten sein. Ziehen Sie das gehaltene Gespräch per Drag & Drop auf den Konferenzschalter.

Alternativ dazu erhalten Sie über der gehaltenen Gesprächstaste ein Kontextmenü, mit dem Sie die Konferenz einleiten können.

Zu einem Gespräch oder einer Konferenz einen neuen Gesprächspartner hinzuholen

Sie können zu einem aktiven Gespräch einen weiteren Partner hinzuholen und machen so eine Dreierkonferenz daraus. Wenn schon eine Konferenz besteht können bei guten Anlagen weitere Partner ins Gespräch geholt werden. Die Vorgehensweise ist in beiden Fällen gleich. Klicken Sie auf den Konferenzschalter.

Es erscheint der Anwahldialog. Geben Sie die Nummer des neuen Teilnehmers ein und bestätigen Sie. Sie können auch in eines der aufgeführten Telefonbücher springen und dort das Telefonsymbol ablegen.

Drag&Drop

Wenn ein aktives Gespräch oder eine Konferenz besteht können Sie auch einfach eine Gruppentaste, ein Gruppensymbol oder ein Eintrag aus dem privaten Telefonbuch auf das Konferenzsymbol ziehen.


Kurzwahltasten auf dem Desktop anlegen

Verwenden der Kontextmenüs

Auf den Gesprächstasten, der Gruppenansicht und den meisten Listen bekommen Sie Kontextmenüs, mit deren Hilfe Sie Verknüpfungen mit Rufnummern auf dem Desktop ablegen können.

Drag&Drop

Sie können Gesprächstasten, Symbole der Gruppenansicht und die Einträge in den meisten Listen auf den Desktop ziehen und haben dann dort eine Kurzwahltaste.


Makeln

Klicken Sie einfach auf das gehaltene Gespräch im Anrufdialog. So können Sie zwischen aktivem und gehaltenem Gespräch hin und her schalten.


Markierten Text anwählen

In den Einstellungen zur Schnellwahl sollte die Anwahl über Tastenkürzel aktiviert sein.

Markieren Sie die Rufnummer im Dokument, welche angewählt werden soll. Sie können nur mit dem Tastenkürzel (Voreinstellung STRG + F12) anrufen.


Nachrichten versenden

Schlagen Sie die Seite "Nachrichten" des Anrufregisters auf. Tragen Sie die Durchwahl des Empfängers ein und senden Sie ihm eine Kurznachricht bis 220 Zeichen. Um eine Nachricht an alle Gruppenmitglieder zu senden tragen Sie im Eingabefeld "Nachricht an:" ein * ein.

Sie können in der Gruppenansicht über ein Kontextmenü ebenfalls Nachrichten versenden.

Das Ziel der Nachricht können Sie über Drag&Drop eingeben.


Netzwerkeinstellungen ändern

Sie finden unten rechts in der Taskleiste das Verbindungssymbol des TAPIMaster® Clients. Klicken Sie mit der rechten Maustaste darauf. Es erscheint ein Kontextmenü. Klicken Sie auf "Netzwerkverbindung". Im folgenden Dialog können Sie alle Einstellungen vornehmen.


Ohne herunterklappende Dialoge arbeiten

Wenn Sie während der Arbeit nicht von herunterklappenden Anrufdialogen oder Gruppenansichten gestört werden wollen, sind ein paar kleine Änderungen in den Programmeinstellungen notwendig. Öffnen Sie die erweiterten Einstellungen. Aktivieren Sie "Keine Anzeige" und "Nichts unternehmen".


Privatgespräche führen

In einigen Firmen ist es üblich dass bei Privatgesprächen nach Extern eine andere Amtsholung verwendet werden muss. Drücken Sie dazu den Schalter in der Clientleiste am oberen Rand des Bildschirms.

Der Schalter ist nur aktiviert wenn für Privatgespräche eine separate Amtsholung reserviert wurde.


Programm deinstallieren

Das Programm lässt sich mit dem Setup auch wieder entfernen. Starten Sie die CTISETUP.EXE. Aktivieren Sie "Programm entfernen" und folgen Sie dem Programm.

Ansonsten lässt sich das Programm über Systemsteuerung | Software deinstallieren.


Reaktionen auf Anrufe festlegen

Öffnen Sie die erweiterten Einstellungen. Wenn Sie selbst angerufen werden kann der Anrufdialog automatisch heruntergeklappt werden. Sollte ein Anruf bei einem Gruppenmitglied auflaufen so kann die Gruppenansicht gar nicht, sofort oder zeitverzögert angezeigt werden.


Registerkarten automatisch zuklappen

Wenn Sie Unterseiten manuell aufschlagen klappen diese nicht zu wenn Sie auf andere Anwendungsfenster klicken. Sie müssen wieder von Hand geschlossen werden. Das lässt sich ändern, wenn Sie in den Grundeinstellungen die Option "Registerkarten automatisch zuklappen" aktivieren.


Rückfragen tätigen

Rückfragedialog

Klicken Sie auf "Rückfrage" in der Anrufseite.

Der Anwahldialog öffnet sich. Geben Sie die Nummer ein und wählen Sie.

Programmleiste

Ein Klick auf eine Gruppentaste startet eine Rückfrage zum Gruppenmitglied.

Telefonbücher

Sie können Rückfragen auch starten wenn Sie in den Telefonbüchern oder Gesprächslisten einfach per Doppelklick eine Anwahl starten.


Rufnummern in das private Telefonbuch übernehmen

Kontextmenü

Über Gesprächstasten und Einträgen der Anruflisten können Sie über ein Menü die Rufnummer ins private Telefonbuch übernehmen.

Drag&Drop

Gesprächstasten oder Einträge in Gesprächslisten lassen sich per Drag&Drop in das private Telefonbuch ziehen. Sollte die Rufnummernidentifikation nicht erfolgt sein dann werden Sie nach einem Namen für den Gesprächspartner gefragt.


Rufumleitungen schalten

Manuell in Programmleiste eintragen

Tragen Sie die Zielnummer für die Umleitung in die Programmleiste ein und klicken Sie auf den Schalter links daneben. Die Rufumleitung ist eingeschaltet.

Drag & Drop

Sie können Gruppentasten, Symbole in der Gruppenansicht, Einträge im privaten Telefonbuch oder in Gesprächslisten auf das Eingabefeld für die Rufumleitung ziehen, welche dann zugeschaltet wird.


Sehen, ob während der Abwesenheit angerufen wurde

Neue Anrufe sehen Sie in der Liste der eingehenden Anrufe. Zusätzlich wird rechts unten in der Taskleiste ein kleines gelbes Telefonsymbol eingeblendet, analog dem Briefsymbol bei Outlook. Sie sehen die Rufnummer im Tooltip und können über ein Kontextmenü zurückrufen.


TAPI zurücksetzen

Es kann in seltenen Fällen vorkommen dass Sie keine Anrufe mehr auflegen können oder der Client nicht auf eingehende Anrufe reagiert bzw. Sie keine Anrufe mehr einleiten können. Öffnen Sie in diesem Fall die erweiterten Einstellungen und klicken Sie auf "Leitung zurücksetzen".


Telefonbücher importieren

Sie können Textdateien in das private Telefonbuch importieren. Aus Datenbanken und Exceltabellen lassen sich solche Textdateien generieren, in denen pro Zeile ein Datensatz steht. Die Felder sind durch Separatoren getrennt. Legen Sie eine solche Datei an. Öffnen sie nun das private Telefonbuch. Klicken sie mit der rechten Maustaste hinein. Wählen Sie aus dem Kontextmenü Laden | Import aus Textdatei. Unterhalb des Telefonbuches wird ein neuer Dialog eingeblendet.

Stellen Sie im Importdialog den Dateinamen ein oder ziehen Sie die Datei aus dem Explorer auf das Namensfeld. Tragen Sie die Position der Felder für Rufnummer und Name ein. Legen Sie den Separator fest. Jetzt können Sie die Datei importieren.


Wahlwiederholungen tätigen

Klicken Sie auf den Schalter "Wiederholung" im Anrufdialog.

Sie können auch die Liste der ausgehenden Gespräche aufschlagen und auf den gewünschten Eintrag doppelklicken.


Zwischenablage senden

Der Inhalt der Zwischenablage (Text) kann zu einem Gruppenmitglied geschickt werden. Im Beispiel wir eine Rufnummer markiert und diese einem Kollegen geschickt. Dieser findet sie dann in seinen Nachrichten, spätestens dann wenn er sich anmeldet.


CTI Switchboard

Beschreibung

Das CTI Switchboard ist eine Client / Server Anwendung. Es ist für Administratoren oder die Sekretärin bestimmt. Der Anwender hat damit den Überblick über alle Telefone und kann alle Gespräche von einem Platz aus steuern. Das CTI Switchboard ist nur Bestandteil der Lizenzversion. Es ist nicht gleichzeitig mit der Server-Programmierschnittstelle einsetzbar.

Installation

Bei der Installation des Servers wird der Switchboard Server mit installiert. Es handelt sich um einen Windows Dienst. Dieser startet standardmäßig nicht automatisch. Setzen Sie den Startmodus auf "Automatisch" wenn Sie das Programm benutzen wollen. Diensteverwaltung öffnen...

Im Startverzeichnis des Switchboard Servers finden Sie eine Datei FCTISBSV.INI. In ihr können Sie den Port (Standard 2520) ändern und ein Paßwort festlegen (empfohlen).

Client

Es kann nur ein Client benutzt werden. Sie finden das Programm im Setup-Ordner des Servers (<Programmverzeichnis>\<Produktname>\Setup\FCTISBCL.EXE. Beim Start werden Sie nach den Verbindungsdaten (Servername + Port) gefragt. Geben Sie ihre eigene Durchwahl und das vorher festgelegte Paßwort ein.

Der Client enthält drei Listen und mehrere Aktionsschalter:

Mitarbeiterliste

Hier sind alle Telefone aufgelistet. Es ist sichtbar wer gerade ein Gespräch hat. Vorhandene Rufumleitungen werden erkannt. Angemeldete Benutzer sind sichtbar, sofern der CTI-Server läuft. Es können Nachrichten an den Benutzer verschickt werden. Per Doppelklick kann ein Anruf erfolgen.

Liste der eingehenden Anrufe

Alle noch nicht beantworteten Anrufe werden aufgelistet. Die Anrufe können per Doppelklick heran geholt werden.

Liste der aktiven Gespräche

Die Gespräche der Mitarbeiter und ihre Gesprächspartner werden gelistet.

Aktionsleiste

Mit der Leiste sind Schalter enthalten mit der verschiedene Telefonanktionen durchgeführt werden können. Je nach aktiver Liste und ausgewählten Eintrag sind nur die Schalter aktiviert welche gerade benutzbar sind.


FAQ

Wenn Sie Fragen zum Produkt haben oder auf Ihrem System Fehler feststellen können Sie sich an den Vertriebspartner wenden. Wichtig sind in diesem Fall folgende Angaben:

·Welches Betriebssystem ist auf dem Server / Client installiert?

·Welche Telefonanlage wird verwendet?

·Möglichst genaue Beschreibung des Problems und der Bedingungen, damit der Fehler nachvollzogen werden kann (ggf. Bildschirmausgaben mitsenden).

Mögliche Probleme beim Einsatz von TAPIMaster®

Client

Server


Client

Alle Telefoniefunktionen versagen

Zunächst sollte geprüft werden, ob nur ein Benutzer oder alle betroffen sind. Wenn die Software überall versagt, sollte auf dem Server mit dem Leitungsbeobachter geprüft werden, ob der Treiber überhaupt funktioniert, insbesondere vor der Installation der Clients sollte das geschehen. Wenn der Treiber nicht funktioniert (Leitungen lassen sich nicht öffnen oder einfache Funktionen wie eine Anwahl schlagen fehl), dann ist hier der Hersteller der Anlage der Ansprechpartner.

Das kanonische Format ist falsch

Die CTI-Software kann die Rufnummern in das kanonische Format umwandeln. Da es in jedem Land hierfür andere und oft keine einheitlichen Regeln gibt, werden z. Z. nur deutsche, österreichische und US-amerikanische Nummern formatiert. Einige Programme wie z. B. Microsoft Outlook benutzen unter Umständen nicht das korrekte kanonische Format. Das kann zu Problemen führen wenn in den Outlook-Kontakten nach der übermittelten Rufnummer gesucht werden soll. Die Rufnummernidentifikation des Clients in den Outlook-Ordnern ist davon jedoch nicht betroffen.

Normalerweise werden die Rufnummern wie folgt umgewandelt bzw. von Outlook gespeichert:

Eingehende Nummer: 0535126226

Outlook: +49 (05351) 26226 (ist falsch)

CTI-Software +49 (5351) 26226

Trotzdem kann es vorkommen, dass Ihnen vermeintlich falsche Nummern angezeigt werden, in diesem Fall z. B. die Nummer +535126226. Die Ursache dafür dürfte schnell gefunden sein. Begeben Sie sich an den CTI Server und starten Sie dort den Leitungsbeobachter. Öffnen Sie eine Leitung und wählen Sie die zu dieser Leitung gehörende Rufnummer mit Vorwahl bzw. mit dem Handy. Jetzt wird Ihnen ein eingehender Anruf mit Rufnummer angezeigt. Sehen Sie sich die Rufnummer an. Wenn diese mit zwei führenden Nullen beginnt (z. B. 00535126226), dann liefert der TAPI-Treiber die Amtsnull mit, und schon wird aus der Volksbank Salzgitter ein Anruf aus Kuba. Das Problem kann behoben werden indem man beim TAPI-Treiber die Übermittlung der Amtskennziffer abschaltet (dazu Handbuch der Telefonanlage durchsehen) oder ganz einfach in der Steuerkonsole auf der Seite „Anlageneinstellungen" eine 0 als Filternummer eintragen. Der Server muss heruntergefahren werden, um diese Änderungen tätigen zu können.

Wenn das kanonische Format bei Ortsgesprächen falsch angezeigt wird (z. B. +49 (521) 56 bei einer Nummer 52156 im Ort), dann ist möglicherweise der TAPI-Treiber nach der Installation des CTI-Servers neu installiert worden. Der Administrator sollte den CTI Server in dem Fall neu einrichten.

Namen der Gruppenmitglieder fehlen

Sie haben den Client installiert und bekommen die Namen der Gruppenmitglieder nicht übertragen. Stattdessen werden in der Gruppenliste nur die Durchwahlen angezeigt. Das ist ein „Fehler", der sich nach wenigen Tagen selbst behoben hat. Der Server wurde so programmiert, dass sich die Namen der Gruppenmitglieder selbst nach deren erstmaliger Anmeldung einpflegen, der Administrator muss dann nicht Hunderte von Namen am Server eintippen. In wenigen Tagen werden Sie in Ihrer Gruppenliste alle Mitarbeiter mit deren Namen sehen, unter denen sie sich im Netzwerk anmelden.

Es kommt keine Anmeldung zustande, obwohl eine Netzwerkverbindung besteht

Vergewissern Sie sich, dass der Clientbenutzer sich mit einem Benutzernamen unter Windows angemeldet hat. Diese Maßnahme dient zur Erhöhung der Sicherheit.

Der Client lässt sich starten, wird aber nicht aktiv

Fragen Sie zuerst nach, ob der Server läuft. Wenn der Client bei den anderen Kollegen aktiv ist, dann ist dieser auf jeden Fall gestartet. Sehen Sie sich nur im Client die Einstellungen für das Netzwerk an. Servername und Portnummer müssen stimmen. Die eingetragene Durchwahl sollte die Durchwahl ihres Telefons sein. Vergleichen Sie die Angaben mit den Einstellungen anderer Clients, wenn Sie Servername und Portnummer nicht kennen. Stimmen diese überein, so können Sie folgendermaßen prüfen ob ihr Computer eine Netzwerkverbindung zum Server hat: Starten Sie das MS-DOS Fenster und geben Sie „ping Servername" ein (Servername durch den richtigen Namen ersetzen). Wenn hier keine Verbindung angezeigt wird, dann wenden Sie sich bitte an den Administrator, damit dieser die Verbindung bereitstellt.

Die Anruferliste bleibt leer

Vergewissern Sie sich, dass Sie die Datenbankschnittstelle mitinstalliert haben. Öffnen Sie die Steuerkonsole des CTI-Servers. Dort sollte eine Registerkarte „Datenbankschnittstelle" vorhanden sein. Schlagen Sie diese auf. Die Option „Gesprächsdatensätze an die Clients senden" sollte aktiviert sein. Wenn die Datenbankschnittstelle fehlt, so installieren Sie den Server bitte erneut mit Datenbankschnittstelle.

Wie kann aus anderen Anwendungen heraus telefoniert werden?

Mit der CTI-Software können Sie aus anderen Anwendungen (z. B. MS Outlook, Wählhilfe) heraus telefonieren. Der Client oder ein anderes Programm welches die Schnittstelle benutzt muss dazu laufen.

Beispiel Outlook:

·Starten Sie Outlook.

·Öffnen Sie den Ordner „Kontakte".

·Klicken Sie mit der rechten Maustaste auf einen Kontakt. Ein Menü erscheint.

·Bestätigen Sie in diesem Menü „Kontakt anrufen". Ein Dialog erscheint.

·Drücken Sie den Schalter „Wahloptionen". Im folgenden Dialog wählen Sie aus der unteren Liste „FCTI Line" aus und bestätigen mit OK. Die Wahloptionen sind nun eingestellt, der Vorgang braucht bei der nächsten Anwahl nicht wiederholt werden.

·Klicken Sie auf „Anruf beginnen".

Viele Programme nutzen einen Telephony Service Provider (TSP), um dem Benutzer die Telefonanwahl zu ermöglichen. Die CTI-Software stellt hierfür einen TSP zur Verfügung, welcher bei der Installation des Clients mitinstalliert wird.

Gespräche werden nach einer Minute plötzlich aufgelegt

Der CTI-Server hat einen Stabilisierungsmechanismus, welcher einige Treiberfehler korrigieren kann. Sollten bestimmte Gespräche plötzlich unterbrochen werden, so liefert der Treiber falsche Statusinformationen, schalten Sie dann die Stabilisierung ab.

Login fehlgeschlagen

Prüfen Sie mit welcher Durchwahl sich der Client anmeldet. Diese muss auf dem Server unter "Durchwahlen" eingetragen sein. Sollte das Login beim Client fehlschlagen obwohl sich das Netzwerksymbol des Clients grün färbt dann ist meist die Durchwahl nicht in den Servereinstellungen eingetragen.

Die Anrufererkennung aus der Datenbank schlägt fehl

Wenn der Server die Rufnummern in das kanonische Format umwandelt so müssen sie auch in der Datenbank im kanonischen Format stehen. Bsp.

Es werden keine eingehenden Anrufe anzgezeigt, die Wahl von den Clients klappt aber

1. Prüfen, ob der Leitungsbeobachter eingehende Rufe anzeigt. Falls nicht, liegt ein Problem im TAPI Treiber / Anlage vor.

2. In der TAPIMaster Steuerkonsole, Seite "Durchwahlen", darf das Häkchen bei "Leitungen nur bei Anruf öffnen" NICHT gesetzt sein.

3. Auf der gleichen Seite sollten nur so viele Durchwahlen eingetragen sein wie auch Lizenzen vorhanden sind. Ausgegraute Durchwahlen deuten auf eine Fehlkonfiguration hin.

4. Nach Änderungen im TAPI Treiber kann es zu Differenzen bei den TAPI Leitungsindices kommen. Im Zweifelsfall auf der Seite "Anlageneinstellungen" die Konfiguration mit "Aktualisieren" neu einlesen.


Server

Server fährt beim Starten gleich wieder herunter

Wenn Sie den Server zwar installiert, die Durchwahlen aber noch nicht eingerichtet haben, beendet sich der Server kurz nach dem Start von selbst. Legen Sie die Durchwahlen in der Bedienkonsole der CTI-Software fest.

Server braucht zum Start sehr lange

Beim Start des Servers werden alle TAPI-Leitungen geöffnet. Bei großen Anlagen kann das mehrere Minuten dauern. Es ist also kein Fehler, wenn sich nach dem Start des Servers zunächst nichts tut.

Server lässt sich nach dem Beenden nicht mehr starten

Nicht nur das Öffnen, auch das Schließen der TAPI-Leitungen kann lange dauern. Wenn der Server als Dienst läuft und in der Phase des Herunterfahrens bereits neu gestartet wird, dann führt das zu Problemen. Es wird empfohlen, nach dem Beenden des Servers etwa eine Minute mit dem Neustart zu warten.

Die Rechenlast auf dem Server ist zu groß

Die CTI-Software wurde so programmiert, dass es schnell und effizient arbeitet und mit wenig Rechenleistung auskommt. Sollte bei großen Installationen die Rechenleistung nicht ausreichen, gehen Sie folgendermaßen vor:

·Prüfen Sie, ob auf dem Serverrechner noch andere rechenintensive Prozesse laufen. Öffnen Sie dazu den Taskmanager mit der Seite Prozesse. Ordnen Sie die Prozesse nach der verbrauchen CPU-Zeit. Sie können nun sehen, welche Programme über einen längeren Zeitraum die meiste Rechenzeit beanspruchen. Wenn möglich, verlagern Sie diese Programme auf einen anderen Rechner. Als Faustregel kann gelten, dass beim Einsatz von Pentium III Rechnern für jeden Client ein Megahertz zur Verfügung stehen sollte, unter der Voraussetzung, dass keine anderen rechenintensiven Programme auf dem Serverrechner laufen. Wenn die Rechenleistung sich auf mehrere Prozessoren verteilt, sollte noch mal 20% aufgeschlagen werden (z. B. Dual-Pentium III je 600 MHz bei 1000 Clients).

·Sehen Sie sich bitte die Programme in der Prozessliste noch einmal genauer an. Sie werden dort zwei Prozesse finden, welche den Namen „SVCHOST.EXE" tragen. Wie sehen deren Rechenzeiten aus? Wenn hier bei einer der beiden Prozesse ein hoher Leistungsverbrauch auftritt ist das meist ein Zeichen dafür, dass der TAPI-Treiber selbst sehr viel Leistung benötigt, ein Problem für das die CTI-Software nichts kann. Außerdem können weitere Prozesse aktiv sein, welche im Zusammenhang mit dem TAPI-Treiber stehen. Notieren Sie sich in diesem Fall den Dateinamen der Anwendung und suchen Sie diese auf der Festplatte. In der Dateiinfo des Explorers können Sie erkennen, welcher Hersteller zu dieser Datei gehört und ob dieser Prozess zu Ihrer Telefonanlage gehört.

·Öffnen Sie die Bedienkonsole der CTI-Software. Auf der zweiten Seite finden Sie die Rufnummernzuordnung zu den Leitungsnamen. Beenden Sie den CTI Server, um Zugriff auf diese Liste zu haben. Löschen Sie die Durchwahlen der Teilnehmer, wo kein Telefon vorhanden ist oder die keine CTI benutzen, z. B. Telefone in Lagern und Montagehallen ohne Rechner.

·Die größte Rechenlast wird durch die Übermittlung der Gesprächszustände zwischen den Gruppenmitgliedern verursacht. Der ungünstigste Fall liegt vor, wenn alle Benutzer in der gleichen Gruppe sind. Setzten Sie deshalb die Gruppen möglichst sparsam ein. Nicht jeder Teilnehmer muss Mitglied einer Gruppe sein. Gruppen werden dann benötigt, wenn die Rechte für einige Funktionen (z. B. das Heranholen von Gesprächen) auf die Mitglieder einer Gruppe eingeschränkt werden sollen. Es ist durchaus normal, wenn von 1000 Clients sich nur 250 in verschiedenen Gruppen befinden, hauptsächlich die Mitarbeiter im Servicebereich.

Rufnummernidentifikation schlägt fehl

Die häufigste Ursache bei fehlgeschlagenen Rufnummernidentifikationen sind fehlende oder falsch eingetragene Filternummern in der Bedienkonsole. Starten Sie den Leitungsbeobachter, lassen Sie sich von außen anwählen und prüfen Sie ob in den Rufnummern des Anrufers eine führende Null enthalten ist, wenn ja tragen Sie in der Bedienkonsole eine Null als Filternummer ein. Ist keine führende Null vorhanden, sollte auch keine Filternummer eingetragen sein.

Wenn der TAPI-Treiber neu installiert wird, ist es erforderlich die Anlageneinstellungen zu aktualisieren. Ansonsten findet das Programm bestimmte Daten wie Amtskennziffern und Vorwahlen nicht.


Preise

Preisinformationen können Sie unter info@tapimaster.de erhalten.

Die nicht lizenzierten Installationen mit 4 oder weniger Clients haben einen eingeschränkten Funktionsumfang. Hier besteht kein Anspruch auf Support.

Bei einigen Herstellern (insbesondere bei größeren Anlagen) ist der TAPI-Treiber nicht im Lieferumfang der Anlage enthalten und muss extra erworben werden, wodurch in diesem Fall Mehrkosten entstehen.

Ein Verkauf an Privatkunden findet nicht statt.

Firmen welche ausschließlich Software herstellen und diese Lösung in ihre Produkte integrieren wollen erhalten für den Eigenbedarf auf Anfrage eine kostenfreie Testlizenz.


Kontakt

Ansprechpartner: | Tino Kasubke
 | Kellerberg 1a
 | Walsdorf
 | 96194
Telefon: | +49 (9549) 989999-0
Fax: | +49 (9549) 989999-1
Mail: | info@tapimaster.de
Web: | http://www.tapimaster.de